View Full Version : Tps disconnected during tps reset help//

02-14-2011, 10:05 AM
when i tried to reset the tps with ecm spy program,i unscrew it until it was 0.0% i reset it. and when i tried to screw it back clock wise it didn't responed and so the throttle.
i unscrew the cable the throttle responed but the tps was still at 0.0%.
maybe the sensor got out? if it is were is the other side conects it?
anybody familiar with the occurrence??
thank you .

02-14-2011, 11:22 AM
I can't tell you exactly where it goes, but it should run up to the throttle bodies under the airbox, just to give you somewhere to start looking.

02-17-2011, 07:55 PM
Pull off the top Air box cover look on the top of throttle body,and see if it popped out make sure you don't drop anything down in any areas that would cause a problem. You may have to remove (To make it easier to work).the 4 screws that hold the bottom piece will give you room to lift up around the Veolcity Stack where it seals. Make sure when you are done w/ the repair to put it back EXACTLY like factory. THE IAT control make sure you plug it back in. Good Luck!

02-18-2011, 04:35 AM
Mine was doing that same exact thing when I tried to reset my TPS on Wednesday. I have no idea why it was doing it, but I think ECMspy was disconnecting from my bike every time I hit the "reset TPS button. I'd unscrew it down to 0%, give it 2 more turns, hit reset TPS, hit OK, then no matter how far I turned it back in it wasn't reading anything. I had to unscrew it again, reset the TPS, then reconnect ECMspy, and then screw it back in.

anyone else's ECMspy ever disconnect from their bike like that??

02-20-2011, 06:13 PM
ya everytime i reset something ecmspy likes to disconnect from my bike.

02-20-2011, 07:07 PM
You have to click the keys in the upper left corner after hitting the reset button.

02-20-2011, 08:07 PM
here is some threads & guides that can help you.
DOWNLOADING-RACE-MAp (http://www.buellxb.com/Buell-XB-Forum/Buell-Lightning-XB12S-XB12Ss-CityX-XB12Scg/Race-Kits/DOWNLOADING-RACE-MAp-tomorrow)
Troubleshooting/TPS-reset-Q. (http://www.buellxb.com/Buell-XB-Forum/Buell-Lightning-XB12S-XB12Ss-CityX-XB12Scg/Troubleshooting/TPS-reset-Q.)
ECMSpy-Tuning-Guide-Ver.-2 (http://www.buellxb.com/Buell-XB-Forum/General-Motorcycle-Chat/ECMSpy-Tuning-Guide-Ver.-2)
ECM-Spy (http://www.buellxb.com/Buell-XB-Forum/Do-It-Yourself-Buell-Mods/ECM-Spy)ECM-Spy-Download (http://www.buellxb.com/Buell-XB-Forum/Do-It-Yourself-Buell-Mods/ECM-Spy-Download)
make sure to Read thoughly several times both ECMSpy guides versions 1 & 2 !

and welcome to the best BUELL forum . here is some more threads for you to check out , lots of great info !
150-Helpful-Links-for-Buellers....and-Growing. (http://www.buellxb.com/Buell-XB-Forum/General-Motorcycle-Chat/150-Helpful-Links-for-Buellers....and-Growing.)
Buell-Clothing--Parts-List---Foreign--Domestic (http://www.buellxb.com/Buells-for-Sale/Buell-Parts-for-Sale/Buell-Clothing--Parts-List---Foreign--Domestic)
pegasusraceteam.com racewear (http://www.pegasusraceteam.com/html/racewear.html)
EBR racing team Donate Page support crew (http://www.ebracingteam.com/index.html)
Erik Buell Racing .com (http://www.erikbuellracing.com/)
Erik Buell & EBR gear & merchandise (http://www.ratpakrecordsamerica.com/erikbuell)

02-20-2011, 08:48 PM
Pretty sure version 2 of the Tuning Guide was an improvement on version 1 - no need to read 1 that I know of.

06-02-2011, 03:27 PM
It's a software "glitch" in later versions of ECM spy. The same thing happened to me repeatedly. I got ECM spy from 2 different sources and both behaved the same way and both were downloaded from different sources, one here in the forum and another source.

I finally gave up getting it to work and thought the problem through after a half dozen failed attempts. It seemed like the TPS reset so after all the failure I dialed the throttle position in manually and the bike ran fine.

Is it 4.8, 5.2 or 5.9%? I have no idea. It doesn't matter to me. It idles and runs better than I expected. You just need to be smarter than the ECM or the throttle.

09-17-2011, 12:46 AM
I used ECMspy for the first time today and had the same or similar problem when setting the TPS. The software reset the TPS OK, then stopped getting realtime data from the ECM. Just checking to be sure it's the software and not another problem. dallasb mentioned keys in the upper left corner, I'll try that.

uly luigi
09-17-2011, 06:42 AM
Tuner Pro, it's way better than ECMSpy

02-20-2012, 08:35 AM
I too first used EcmSpy to reset my TPS the other day and after hitting the reset button it seemed to loose the connection. I was freakin out for a a bit until I read this post. And My version of EcmSpy V.1.12.27 would read again after hitting the upper left keys button that opens up the small closed/open loop window. On this forum you can watch a you tube video by of one of our members resetting his TPS and he too opens this little window, but he doesn't explain anything about it.
It works and that's all I care about.