View Full Version : 08 blast tripometer not working

05-03-2013, 07:28 AM
alright i just purchased a 2008 blast for a starter bike and i came to found out this bike doesnt have a fuel light and everyone reccomends to just use the trip meter to measure how much fuel is left so i went out to mine and put the key into the on position and press in the button on the speedo to switch it and nothing happens even if i hold it.
i also noticed that when ever i put on my turn signal on the speedo is always shows that the right signal is on even if the left is on and i have checked them manually to see if there lit up properly and they are just not sure if these two things are related or how to go about fixing this issue.

05-03-2013, 07:52 AM
If you hold I it resets. Also, the tank has a reserve so when the main part of the tank is low, switch to reserve and get gas. Check battery power and clean the speedo sensor

05-03-2013, 07:59 AM
Yeah I know that if you hold it resets. What I'm saying is the button won't even switch from odometer to trip. I tried to put the speedo into diag mode by holding down the reset button and switching the ignition to on and nothing happens so I'm left to believe ether the switch is bad or the wiring into the gauge is bad.
My question now is can you buy a replacement switch or do I have to by a hole new speedo

05-03-2013, 08:14 AM
The ignition and speedo are separate., so does the speedo show nothing at all? Not just trip but not even mileage?

05-03-2013, 08:56 AM
Alright so while riding it I tried it and it switched to trip so I held it in and it wouldn't reset it just keeps flipping back and forth between trip and ODO.
As for the ODO it works and shows correct mileage and the speed shows up fine

05-04-2013, 08:45 AM
Your button is just wore out. Leave it alone in Odo mode or buy a new one.

05-04-2013, 12:43 PM
yeah Ive messed with it some more and sometimes itll work right and sometimes it wont. im thinking about trying and finding a broken speedo and swapping the buttons out to mine or something similar.

05-15-2014, 03:05 AM
I know this is a little late for a response, but here is what you have to do;

Hold down the rubber boot on the trip meter switch and turn it counter clockwise. The rubber boot is fastened to a little skinny plastic nut. The rubber and the nut will come off together and then blow out the switch and clean the nut and boot and reinstall. Look at the connector on the wires going to the switch and see if the pins are clean and the connector is tight.

That should get it working again

Kenny G