PDA

View Full Version : Any one have oil light problems



roadrocker
10-11-2009, 03:43 PM
Okay just got my bike back from dealer and they couldn't find a problem but on the way home the oil light came on !!!!! If you lean the bike to the left the light goes off. What the hell!!

Geforce
10-11-2009, 06:20 PM
You mentioned they updated the ECM not to long ago right? I am not sure what would cause the oil light to come on...

How many miles do you have on it?

Do you know how to do the PROPER oil check on it? (There's two... hot and cold)

Have you had any issues with your incstrument cluster?

What year model is it?

roadrocker
10-12-2009, 01:39 AM
I have a 08 1125r and I have 6000 miles on it. I haven't had any instrument panel problems yet. The ECM was done last month for the second time but everything seems fine now .
I didn't know there was a hot oil level check for it. Can you tell me how to do it? I have always had JAP bikes and never had to do a hot oil check. thanks all for the reply's. I got rid of the stock rotor and went with different pads so that problem is done with. they did replace the stock one under warranty. The dealership was being difficult until I called Buell and then there attitude changed Quick!!! I really must say thanks to Buell for that.

Geforce
10-12-2009, 01:46 AM
Go to Buell's website...

Register on the OWNERS section.

Download the 2008 1125r Owner's manual. The complete instructions are there... DO NOT ADD A BUNCH OF OIL. The hot and cold checks will read different and the best thing to do is average them out. The 2010s have a sight glass now for an even easier check. If you are totally lost. Just let it be. These motors burn very little oil.

Keep up the good attitude and Buell will get you going.