PDA

View Full Version : Trip Odometer Resetting to 0 miles



larnanc
11-27-2009, 07:45 PM
Hey...
Just joined this forum and already need your help/advice! I just aquired a 1999 Buell Lightning X1 that is almost mint and I LOVE it! Kinda fun cuz I'm an old bird...59.....LOL! Every time that I shut it down, the trip odometer always resets to 0 miles. It accumulates trip miles as it should, as I ride, but the minute ya turn the key to OFF, it resets the trip odom back to zero. Makes it difficult to check the fuel consumption on her. Any ideas? Everything else on the odometer/speedometer works perfectly. Thanks a bunch...........

theoctopus
11-27-2009, 07:59 PM
Battery is dying.

Or you have a short in the system.

Start by checking that your battery is pushing 12V appropriately.

Stevenc150
11-27-2009, 09:48 PM
Any auto parts store will check the battery under load, for free.

Edit: Oh, and Welcome to the Forum [up]

Buellysses
11-27-2009, 10:57 PM
I'm not all that familiar with the tubers, but most instruments will have a +12v switched wire and +12v constant wire. Usually the constant voltage is just used to keep the clock/trip odo and the switched runs everything else.

I'd guess that you lost the 12v constant. I don't suppose you have a service manual for that beast?

Do you have any trouble starting the bike?

racepro716
11-28-2009, 02:10 AM
59!!! Geeze, didn't know people lasted that long. 46 here and on my first Buell(08XB12-R), and also loving it. Welcome to the club. Wayne