Search:

Type: Posts; User: rmorris4437

Search: Search took 0.11 seconds.

  1. Replies
    11
    Views
    937

    Thanks for the battery info!

    Thanks for the battery info!
  2. Replies
    11
    Views
    937

    Just a follow up. This ended up being a loose...

    Just a follow up. This ended up being a loose ground. I had checked them all 8 months ago but apparently vibration takes itís toll. Thanks to all who responded with suggestions. Happy New Year!
  3. Replies
    11
    Views
    937

    Thanks Lunaticfringe, Iíll give that a try after...

    Thanks Lunaticfringe, Iíll give that a try after Xmas. Whatís your recommendation on a new battery if I end up needing one?
  4. Replies
    11
    Views
    937

    Thanks Cooter, Iíll start down that path.

    Thanks Cooter, Iíll start down that path.
  5. Replies
    11
    Views
    937

    I cleaned the grounds 6 months ago when I was...

    I cleaned the grounds 6 months ago when I was troubleshooting a charging problem. The battery is only 2 years old but it has been run flat a number of times. Iíll have it load tested. Thanks for...
  6. Replies
    11
    Views
    937

    Starting/Electrical problem

    Hi, I have a 2006 XB12R. When I turn the ignition on, the headlight comes on but the gauges donít sweep. When I turn the kill switch on the fuel pump doesnít cycle. When I hit the start...
  7. Thread: No Power

    by rmorris4437
    Replies
    7
    Views
    542

    Thanks for your help Cooter. It ended up being...

    Thanks for your help Cooter. It ended up being the key switch relay that was causing the fuse to blow. I ended up replacing all three relays for good measure and she fired right up. I guess I...
  8. Thread: No Power

    by rmorris4437
    Replies
    7
    Views
    542

    Thanks for the feedback. Didn't consider the...

    Thanks for the feedback. Didn't consider the relay.
  9. Thread: No Power

    by rmorris4437
    Replies
    7
    Views
    542

    No Power

    OK so I'm an idiot! My battery was dead, it was dark out and i accidently hooked up booster cables backwards to the battery. Now I get nothing. I've had the battery tested and recharged and it's...
Results 1 to 9 of 9