Search:

Type: Posts; User: Thunderhead

Search: Search took 0.06 seconds.

  1. So everything is installed now. So jealous cuz...

    So everything is installed now. So jealous cuz older threads mentioned 'oh yeah, got a whole set off ebay for $50'.... That was then, this is now. Here's the breakdown circa 2020
    Brackets, used,...
  2. Yeah, I'm Captain Cheapo as well. That's why I...

    Yeah, I'm Captain Cheapo as well. That's why I was wondering, I have 2 left side pegs + pins +springs just lying around. Seemed silly to buy 2 more when I had 1/2 a set.

    34:19 - Bummer. I...
  3. Replies
    4
    Views
    105

    WTB: Center tail section 2007 XB

    Mine was cracked when purchased, I have the license plate bracket, only need the section that connects the rear tail section. Seeing on ebay for about $150, seems like a lot.
    Thanks
    13275
  4. And....the answer is no. There's a detent on the...

    And....the answer is no. There's a detent on the bottom side of the passenger peg that coincides with a different spring and little ball bearing. The peg fits but i looks like it won't properly mate...
  5. I found that the two cables coming off the...

    I found that the two cables coming off the throttle were too tight and didn't allow it to get fully slack / go to zero. Easy. Maybe.
  6. Can you use rider pegs for the passenger?

    Hello again!
    So my bike never came with any passenger stuff so I don't know what it's supposed to look like. Just got the brackets and swapped in an old left peg (rider) on the the passenger, it...
  7. Replies
    9
    Views
    799

    Mmhhmm. Checked out that thread, zoomed in on the...

    Mmhhmm. Checked out that thread, zoomed in on the 2nd pic. That's the same as mine.
    So what year did compatibility/accurate swapability end? Cooter's saying possibly 2003. Or is it '05? '07?
  8. Replies
    9
    Views
    799

    Sorry been meaning to get back to this - So what...

    Sorry been meaning to get back to this - So what Gunter said is what I'm wondering. Since it's an '07 I wonder if he put on the 'older' one which I've read will put the speedo about 20% off. That's...
  9. Replies
    9
    Views
    799

    what speedo should my 2007 xb9 have?

    Believe me I have searched and searched. I can't seem to find a definitive answer or trustworthy image. What should a stock 2007 Lightning xb9sx speedo/instrument cluster look like?
    Previous owner...
  10. Replies
    32
    Views
    1,924

    Following up: so before this problem, I changed...

    Following up: so before this problem, I changed rocker box gaskets, changed oil/filter, changed primary oil, and did the obligatory TPS reset. Who knows the last time that was reset. Reassembled once...
  11. Replies
    32
    Views
    1,924

    Nope, that's all me. 2 other people read it and...

    Nope, that's all me. 2 other people read it and interpreted it the way you meant. The separate paragraph should been a sign.
    Yeah I've used the zip tie trick before, works great. This is...
  12. Replies
    32
    Views
    1,924

    oh my. So I read Chickn's reply as "remove...

    oh my. So I read Chickn's reply as "remove stack...can you use more than 20%? throttle (next line) Yes - CPS...." I interpreted that as if it runs well without the stack, that's indicative of a bad...
  13. Replies
    32
    Views
    1,924

    OK, so removed ONLY the stack and it runs great....

    OK, so removed ONLY the stack and it runs great. How the hell is a rubber seal related to detecting potential CPS failure? That sensor is down on the engine casing not way up top. It was really...
  14. Replies
    32
    Views
    1,924

    As far as the velocity stack - you mean remove...

    As far as the velocity stack - you mean remove just the rubber and reinstall everything else? Or just run it with no stack/filter/box?
    CPS = cam or crank position sensor??
    I'll look up past posts...
  15. Replies
    32
    Views
    1,924

    Got the new plugs gapped & installed today. Used...

    Got the new plugs gapped & installed today. Used the same plugs and gap specs previously as well.
    Tried to ride it to get a proper warm up/test ride and the more than 20% throttle problem is still...
  16. Replies
    32
    Views
    1,924

    Wow. Yeah that is a very black spark plug, not...

    Wow. Yeah that is a very black spark plug, not the oily kind and this thing is virtually new. Dr. Internet says 'overly rich fuel mixture'. My manly gasoline musk will also tell you that.
    Not mine...
  17. Replies
    32
    Views
    1,924

    Yes I rotated engine. Checked all plugs/wiring...

    Yes I rotated engine. Checked all plugs/wiring near the pulley, they all looked great. Unplugged them all to inspect for corrosion & such. Looks great.
    Double checked fuel injectors. The green wire...
  18. Replies
    32
    Views
    1,924

    Yes checked the velocity stack - good seal. As...

    Yes checked the velocity stack - good seal. As far as ECMSpy - def not well versed. First time using it honestly. I have spent HOURS reading tons of other posts attempting to troubleshoot this & how...
  19. Replies
    32
    Views
    1,924

    annnnnddddd...that didn't fix it. So when I reset...

    annnnnddddd...that didn't fix it. So when I reset everything I only had it mostly buttoned up. That was without air filter and other assembly. Since I've correctly reset TPS and set idle - it's back...
  20. Replies
    32
    Views
    1,924

    HAHA!!! After a bunch or failures, I tried...

    HAHA!!! After a bunch or failures, I tried running ECMspy (wired) as an administrator. Not much better. Had some privileges but def not all. Then I hit all the buttons (not really) and toggled...
  21. Replies
    32
    Views
    1,924

    TPS not responding on ECMspy

    Hello there! Long time lurker, 1st time poster. So I did A LOT of searching before posting. Good lord this place is a gold mine.
    Bike is an 07 XB9. Just replaced rocker cover gaskets, buttoned...
Results 1 to 21 of 21