Search:

Type: Posts; User: desotonorsocal

Search: Search took 0.13 seconds.

  1. Replies
    15
    Views
    3,903

    I had a similar electrical problem- Do you have...

    I had a similar electrical problem- Do you have an aftermarket seat? Even if not, check the two main connections from the ECM and see how they might be rubbing on the seat. Pull the seat, bend the...
  2. Replies
    24
    Views
    3,702

    @Tork, Thanks! I finally pulled all of the...

    @Tork,

    Thanks!
    I finally pulled all of the plastic bits to trace all cables (ground, etc, as you suggested) and found nothing wrong. But when I was reconnecting the air/fuel sensor (?) (the...
  3. Replies
    24
    Views
    3,702

    Hey all, I know this is an old thread, but I'm...

    Hey all,

    I know this is an old thread, but I'm trying to dig up info rather than just making a new post. I've been digging in online everywhere and this *seems* to be close to the problem I'm...
  4. Replies
    1
    Views
    990

    WTB - ECM for 2006 Buel XB9CityX

    Pretty sure my ECM is fried- Engine won't start, jumping the diag connector has the CEL showing me basically *all* codes, heh, so I'm on a mission to start replacing stuff.

    I've got a stock (other...
  5. @Firefight100 - Are you still selling these?...

    @Firefight100 - Are you still selling these?
    Thank you,
    -DeSoto
  6. I've got a set of stock '06 XB9 lollipops;good...

    I've got a set of stock '06 XB9 lollipops;good condition except for some uber light rust where chipped paint from wrenches exposed the metal but can be sanded off in 2 minutes- I'm in Long Beach, CA...
  7. Replies
    2,754
    Views
    678,108

    Sticky: Hey all- Not new to Buell forums but new to...

    Hey all- Not new to Buell forums but new to BuellXB- Used the site enough I figured it was time to post-- Where better than photo uploading to show off why I'm here in the first place! I have to say,...
Results 1 to 7 of 7