Search:

Type: Posts; User: Markxb9

Search: Search took 0.04 seconds.

  1. Replies
    7
    Views
    708

    where is the best place to get XB frame pucks???

    where is the best place to get XB frame pucks???
  2. Replies
    23
    Views
    1,707

    Update Bike is running great and i hope to put...

    Update Bike is running great and i hope to put some miles in this weekend.
    The problem was crap in the tank. I removed and cleaned the fuel pump / screen. I also re-flashed my ECU and did a...
  3. Replies
    23
    Views
    1,707

    My bike is a little odd....there is no ground at...

    My bike is a little odd....there is no ground at the steering neck i took all this apart a while ago and nothing attached to head stem but previous owner has added extra grounds running back to the...
  4. Replies
    23
    Views
    1,707

    Ok update, re-flashed the ECU last night and...

    Ok update, re-flashed the ECU last night and did a TPS reset. bike started great. Ran for 15 min and then loses all power above 3000 RPM again.
    However I now got a few error codes: 15 Air Temp...
  5. Replies
    23
    Views
    1,707

    Thank you everyone for the help and suggestions. ...

    Thank you everyone for the help and suggestions. I am still trying to resolve the problem. I am going to try and check the TPS and CPS sensor before I move to the ECU
    I think i will also...
  6. Replies
    23
    Views
    1,707

    Re-did tps last night and bike runs great still...

    Re-did tps last night and bike runs great still for 10 - 15 min then it will not rev past 3500 rpm. Problem must be something other than the TPS.
    I still have no codes or check engine light.
  7. Replies
    23
    Views
    1,707

    Ok are you guys messing with me? I have re-read...

    Ok are you guys messing with me? I have re-read and went over the procedure as recommended. I got the info from buelltooth.com web site?
    what step did i miss?
  8. Replies
    23
    Views
    1,707

    ????? What was my error.....any help would be...

    ????? What was my error.....any help would be much appreciated before I send the bike to a shop??????
  9. Replies
    23
    Views
    1,707

    Note.... no check engine or codes when checked...

    Note.... no check engine or codes when checked with ECM Droid AVF was at 120
  10. Replies
    23
    Views
    1,707

    wont rev past 3000 feels like rev limiter kicking...

    wont rev past 3000 feels like rev limiter kicking in.... Just revs to 3000 and nothing more.
    Steps i did for TPS reset.
    Turned idle all the way to the left checked that it was at 0 degress and...
  11. Replies
    23
    Views
    1,707

    2003 XB9s wont Rev past 3000 after warm up

    Help.....Please

    2003 buell xb9s with Race ECM Factory Race pipe and air filter with the air box cut open.
    Bike was running but a little twitchy on the throttle. I did a TPS reset now the...
  12. Replies
    58
    Views
    25,105

    I Have a 2003 XB9s lighting and I do not have any...

    I Have a 2003 XB9s lighting and I do not have any ground on the front triple clamps or the head set is this normal, Wire harness does not have any extra wires?
  13. Thread: Speedo Problem

    by Markxb9
    Replies
    3
    Views
    615

    No the cluster is used, I got another one from...

    No the cluster is used, I got another one from a member on Facebook Both Clusters do not sweep with key..... But they do sweep when I first plug them in.

    Ignition relay? Bike still starts...
  14. Thread: Speedo Problem

    by Markxb9
    Replies
    3
    Views
    615

    Speedo Problem

    Hello, I have a 2003 xb9s I bought used and it came with a large ugly RPM Gauge only. I ordered a Factory Buell speedo.
    When plugged my signals work and show on right side of tack and high beam...
Results 1 to 14 of 14