Search:

Type: Posts; User: jkinzer

Search: Search took 0.06 seconds.

  1. Any fixes?

    Any fixes?
  2. Yeah it is some Chinese stuff I just went out and...

    Yeah it is some Chinese stuff I just went out and looked because I wasn't sure what brand it is. I can't even remember what it is because I noticed my registration light was on with the key not in...
  3. Btw, it does have all stock lights. I did pull...

    Btw, it does have all stock lights. I did pull apart the 77 connector so to check on it so that could have something to do with it being ok the second time around
  4. Ok. I'm starting to think my battery is on its...

    Ok. I'm starting to think my battery is on its way out but still not entirely sure why it ran fine for a week and then just decided.to not start after sitting for a day. Battery has a little display...
  5. Ok, well I tore into the beast today and went...

    Ok, well I tore into the beast today and went over the list of things to check. The 30A fuse was in normal/good condition, 77 connector looked good as well, no grounds were in bad shape but still...
  6. I appreciate the help! The only thing I have done...

    I appreciate the help! The only thing I have done so far is remove the small primary cover and smell the
    fluid and it doesn't smell like anything electric burnt. I am moving tomorrow so it will be...
  7. 06 Buell XB12X ulysses stator or regulator issue

    I recently purchased a 06 XB12X ulysses with roughly 7.5k miles on it. I rode it for about a week putting roughly five hundred miles or so on it in that time frame. Towards the end of my ride the...
Results 1 to 7 of 7