Page 1 of 10 123 ... LastLast
Results 1 to 10 of 99

Thread: "THE PROBLEM" noone knows how to fix

  1. #1
    i have posted here before stating that my 06 xb9sx has been running "rough" (other thread)... it was huccuping, laggin throttle.. etc etc etc.. and the harley/buell shop has done absolutley EVERYTHING to the bike minus tearing down the engine and putting it back together... (cause quite frankly..im not paying a fortune to get the engine torn down and rebuilt).....

    most recently i ordered a programmed race ecm offline with everyone thinking that it was the last thing we could do.. it didnt work.. so im left with a huge bill to pay and STILL a bike that doesnt run right.. i have NO IDEA what to do anymore.. anyone got anything



    edit: locked other thread and posted link here to have complete history and no dubble posts

  2. #2
    Senior Member
    Join Date
    May 2008
    Posts
    6,470
    Do a TPS reset and put in new fuel and new spark plugs. If those dont work, look at your fuel pump.

  3. #3
    done it, done it, and done it....none of those things worked... ill double check on the fuel pump,,but im for sure they already checked that too...

  4. #4
    Senior Member
    Join Date
    Feb 2009
    Posts
    1,352
    What RPM are you having hiccups and lagging throttle?

  5. #5
    well the shops its at is an hour and a half away... but it runs rough ALL THE TIME now... it used to do it after 10 minutes or so of trouble free riding.. and after i took it to the shop and they started getting into it, it just got worse.. now it runs rich/rough all the time

  6. #6
    Senior Member
    Join Date
    May 2008
    Posts
    6,470
    Normally, whenever its a progressing issue, it's the fuel pump.

  7. #7
    well im pretty sure that got checked.. but i will call them first thing in the morning..

  8. #8
    Senior Member
    Join Date
    Mar 2010
    Posts
    7,805
    take off the d&d pipe put your old ecm in and see if that does it.what altitude are you at.

  9. #9
    i dont have the stock pipe... or a stock ecm... and i live in west georgia/alabama border

    are stock exhaust and stock ecm's pretty inexpensive?

  10. #10
    Senior Member
    Join Date
    Mar 2010
    Posts
    7,805
    d&d pipe is a pain in the ass for some.i do a tps reset a few times a week it helps alot but mine is an 09.i also took some baby food lids the metal ones and played with different holes drilled in them until i got rid of my hesitation at 4300 rpm then made some stouter ones.i dont know if this will help you but it worked for me.o9 12scg d&d breather reroute open air box.



Page 1 of 10 123 ... LastLast

Similar Threads

  1. Odd problem....
    By Radiati0n in forum Buell Firebolt XB12, XB9
    Replies: 7
    Last Post: 07-18-2012, 06:41 PM
  2. ECM problem need help!!
    By J20tD in forum Buell Lightning XB12S, XB12Ss, CityX, XB12Scg
    Replies: 5
    Last Post: 05-20-2012, 03:07 AM
  3. I have a problem!!!!!!!! Please Help
    By jtown125 in forum Troubleshooting
    Replies: 18
    Last Post: 04-07-2011, 09:33 PM
  4. anyone one else have this problem
    By 08supermoto in forum Buell Firebolt XB12, XB9
    Replies: 7
    Last Post: 09-21-2010, 10:37 AM
  5. what might be the problem?
    By monkeyn9ne in forum Troubleshooting
    Replies: 4
    Last Post: 08-19-2010, 01:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •