Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 46

Thread: Anyone familiar with Buell ECM stuff? ECMSpy etc?

  1. #21
    I was wondering if anybody else has experienced this...this is probably 10+++ datalogs to get to this point and now I have to pay IDS to reconfigure my existing ECM....The tuning portion he has been awesome...the idle issue has been the hurdle he has been struggling with...between the IAT settings, insulating the wire to the sensor, merging EBR files, now running into some "auto zeroing" issue...I just wanted to see if some of the senior Buell forum guys had a similar stuggle...that what I thought the forum was about??? Help a fellow Buell enthusiast in need...

  2. #22
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Posts
    2,367
    My advice was to stick with what your tuner recommended.

    If I was doing your tuning, and asked you to do something, and you chose to go elsewhere... well that would be the end of that. All those datalogs for nothing.

    I think I know whats happening here, but the tuning and running in open loop is adding a whole bunch of variables, who knows whats been changed and whether its correct or not. Only Dave knows as running in open loop is his thing. Sounds like the firmware has been corrupted to me.

    So, the tuning portion has been awesome up until the point he asked you to spend money?


    I thought this was what you asked:

    Quote Originally Posted by mpkopish View Post
    Anybody have any suggestions/comments to solve this issue?
    This is more likely what you meant:

    Quote Originally Posted by mpkopish View Post
    Anybody have any suggestions/comments to solve this issue that I want to hear and will not cost money?
    Obviously my advice and your tuners advice are not valid.
    Last edited by 34nineteen; 10-15-2020 at 11:42 PM.

  3. #23
    He also is not guaranteeing this will fix the issue because I think he is stumped. And when I spoke to Tim at IDS he cannot guarantee that the files will be compatible with the ecmdroid/spy files as he said he is not familiar with it. So I have 2 sources not guaranteeing success. That is why I am reaching out to the forum as the experiences with situations is vast amongst a forum? We are 95% percent there as the bike perform great but idle stoplight to stop light is the problem. In heavy traffic its very annoying to be at 1300 rpms and the start hunting from 1050 to 1300. Takes all the good out of it....

  4. #24
    Oh I forgot...If I do a TPS reset...its perfect...until I shut the bike down and restart....

  5. #25
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Posts
    2,367
    Now this information is helpful. I'm with them on thinking this is likely a firmware issue, but I couldnt guarantee it.

    A "certain forum member" wound up discovering a weird driveability issue that turned out to be a bad ECM, which baffled all of us as it gave no clues of being defective.

    Is it running rich when it starts hunting or lean? Unfortunately, running in open loop is going to make it difficult to tell, but maybe you have access to a portable sniffer?


    The problem with most of my advice is that it is going to be to unwind most of Dave's tuning and modifications. I will state that I am NOT a better tuner or more knowledgable than he.
    Last edited by 34nineteen; 10-15-2020 at 11:57 PM.

  6. #26
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Posts
    2,367
    Quote Originally Posted by mpkopish View Post
    Oh I forgot...If I do a TPS reset...its perfect...until I shut the bike down and restart....
    Which would lead me to think the firmware is corrupted.

    You may be fighting two problems, also.
    Last edited by 34nineteen; 10-16-2020 at 12:02 AM.

  7. #27
    when I check the IAT setting after doing the TPS reset and running it is at 97% so it tells me it is leaning it out...correct? When I shut the bike off and restart it goes back to 100% as if the TPS is going back to default after cycling the power- which is Daves theory. And since he was using a EBR tune he said there was there is some type of auto zero funtion that is used in a BUE2D firmware. Thats why he wants to try upgrading the firmware...does that make sense?

  8. #28
    And by the way it originally wasn't about the money because I initially spent 300, + 150 with IDS, 180 with EJK-piggyback tuner, and 180, +150, + 50 with David. If it was my harley or most Japanese bikes I would have used my powervision and been done with it...

  9. #29
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,335
    Quote Originally Posted by mpkopish View Post
    If it was my harley or most Japanese bikes I would have used my powervision and been done with it...
    Unless they had a firmware issue, like you're having now.

  10. #30
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,335
    I had an ECM with BUEIX firmware that would revert the AFV to the previous value after the key was cycled. I had HD update the firmware to the latest available (BUE2D) and the only way they do it, comes with everything including the latest factory tune offered.

    It fixed my AFV re-set problem (and they had heard of that issue with that firmware), but I was unable to use my original tune because different firmware versions are NOT compatible. Dave from Buelltooth knows this and it is the same thing he is telling you. Any attempt to defeat the ECM burning safeties and re-install your tune after the firmware change could leave you with a plastic brick that looks exactly like your ECM.

    *Technically (if anyone cares), the different firmware versions hold the fuel map in different areas of the ECM's memory and thats why they stop running. Basically the program can't find its values.



Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Anything Look Familiar?
    By 2004xb12s in forum General Motorcycle Chat
    Replies: 8
    Last Post: 01-17-2013, 12:30 PM
  2. FS- Buell stuff
    By Bossanova in forum Buell Parts for Sale
    Replies: 27
    Last Post: 08-07-2012, 01:03 AM
  3. People of New England familiar with ECMspy
    By AudiXB12R in forum Buell Firebolt XB12, XB9
    Replies: 1
    Last Post: 05-07-2010, 03:52 AM
  4. Buell PART OUT AND OEM TUBE FRAME STUFF TONS OF BUELL STUFF
    By Dinuns1 in forum Buell Parts for Sale
    Replies: 0
    Last Post: 11-15-2009, 04:46 PM
  5. This ECMSPY stuff
    By HOVERJOCKI in forum Buell Lightning XB12S, XB12Ss, CityX, XB12Scg
    Replies: 9
    Last Post: 10-02-2009, 04:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •