Results 1 to 10 of 10

Thread: ECMSPY being cantankerous- Windows 8

  1. #1
    Senior Member
    Join Date
    Jan 2011
    Location
    Kokomo, In
    Posts
    380
    So I've had NO luck with getting ecmspy to work with my laptop. I plug in the cable, turn on the bike and my computer recognises there's a serial adaptor cable plugged in (as per the devise manager) but I'm having 2 problems:
    1) right-clicking on the "!" in the device manager and ther error says something about an object that doesn't exist?
    2)ecmspy shows no com ports available on the drop down menu when I try to select one (mine is set to com5 via the driver config). Trying to autodetect a port in ecmspy brings up the ever popular "com port not found" message.

    Anyone have any advice on getting this thing to work?
    I can sort-of fumble my way around a computer but I'm no tech-junkie by any means.

    thanks.

  2. #2
    Senior Member
    Join Date
    Jun 2013
    Posts
    383
    Did you download the driver for the usb cable. If you don't have the correct driver, the usb won't work correctly.

    I have a FTDI Cable assembly and downloaded the driver from the FTDI Site. If you have a different maker, then go to their site and install the driver for your specific usb cable.

    Cheers!

  3. #3
    Senior Member
    Join Date
    Jun 2013
    Posts
    383
    VCP Driver
    Apologies, here's a more specific link to FTDI VCP Drivers.

    Cheers!

  4. #4
    Where can I get ECM Spy? I'm new to this and definitely feel like I need it.

    I have a Windows 7 system dedicated to bike and car tuning.


    Please help! any information is greatly appreciated.

  5. #5
    Senior Member
    Join Date
    Jan 2011
    Location
    Kokomo, In
    Posts
    380
    Where can I get ECM Spy? I'm new to this and definitely feel like I need it.
    A search of the forums should turn up a link for ecmspy. If all else fails, PM me an email address and I can send you a copy. Be aware though, it only works on pre-07 Buells.

    **A little update on my situation:
    I've finally located the correct drivers though windows 8 is none too friendly with them. Apparently, I need and obsolete version of the driver, which is easy enough to get, but Windows keeps "helping" me by automatically getting the updated driver. Still, I can get the errors to go away and it to recognize the serial/usb adapter.

    My real problem is that I still can't connect to my bike and I think I know why. My bike came with an EBR ecm installed that's programmed for the Jardine pipe. Some Google digging though has brought up that a number of people believe that the EBR ecm's are locked so that ecmspy will not work. I haven't tried putting the original ecm back in (fortunately, it came with the bike) and trying to connect. I really don't want to do that until I can find a good reliable map (or better yet, full EEPROM) for a Jardine. The EBR one works great and the maps seem very good, I just wish I could get a copy of the fuel and spark maps on this thing to load to the stock ecm so I can use ecmspy.
    Eventually, I'm sure I'll figure it out. :(

  6. #6
    Senior Member rchuff's Avatar
    Join Date
    Apr 2012
    Location
    Willow Grove, Pa
    Posts
    2,014
    I have windows 8 and an ebr ecm and have no problem . I use it to do tps resets and afv resets. Are you clicking on the two keys above the overview tab?

  7. #7
    Senior Member
    Join Date
    Jan 2011
    Location
    Kokomo, In
    Posts
    380
    I have windows 8 and an ebr ecm and have no problem . I use it to do tps resets and afv resets. Are you clicking on the two keys above the overview tab?
    Interesting....
    I've tried just about everything I can think of at this point.

    Initially, when I'd go to "get port" there would be none listed.
    By using the obsolete driver I get a port # listed and I get the "got port" message from ecmspy. However, when I try to "get eeprom" to back it up it just times out and it just won't get anything from the ecm. I just assumed that the EBR ecm was locked out as there were a lot of people claiming ebr's are locked on badweb.

    I guess I'll have to try some more when I get a chance.

  8. #8
    Junior Member
    Join Date
    Feb 2013
    Posts
    17
    If you're just going to be testing to see if it's the EEPROM that's locked, you can swap in the stock ECM, and power it up. If you're concerned about the tune, then just don't start the bike! You can flash maps with the key on and run switch set to on, and never need to actually fire the motor.

    Plus, the specific "Race" ECM is just the standard ECM with the Race Fuel & Spark Maps, as well as the white wire mod done internally, along with a few other small changes (notably, being tune locked).

    Get a copy of the Race Map for your year bike/ECM saved to your tuning laptop, swap the ECM's, and see what it does. If it will Fetch the EEPROM, then you know the race ECM is to blame. If it still won't fetch, then you have another issue.

    I found with my Win8 Laptop, it wouldn't talk to the ECM until I ran it in Windows 7 Compatibility Mode. Find the folder the program installed to (probably c:\program files (x86)\ecmspy\ ) and right click the ecmspy.exe file. Go to properties, and then the second tab is Compatibility. You should be able to choose to run ECMspy in WIndows 7 mode.

    Hope this helps. I know the race maps are available online at several different places. If you can't find them, let me know and I'll try to dig up a link.

  9. #9
    Senior Member
    Join Date
    Jun 2013
    Posts
    383
    My bike also came with similar mods. Jardine RT-1 and the race ecm. I was running windows 7 and then upgraded to windows 8 end of last year and I haven't had an issue with drivers or the ecmspy software while using the FTDI cable.

  10. #10
    You must hit the set of keys in the top left corner. I had the same problem once you hit the keys a little side screen should pull up showing a couple bike settings. Then you should be able do do whatever you want.



Similar Threads

  1. ECM spy and windows 7
    By edipis in forum Buell Lightning XB12S, XB12Ss, CityX, XB12Scg
    Replies: 8
    Last Post: 08-26-2013, 07:21 AM
  2. ECM SPY Windows 8
    By gater in forum Buell Lightning XB12S, XB12Ss, CityX, XB12Scg
    Replies: 7
    Last Post: 08-26-2013, 03:41 AM
  3. Replies: 0
    Last Post: 02-02-2011, 03:49 PM
  4. ecmspy on windows seven starter?
    By bttrfngrz in forum Buell Firebolt XB12, XB9
    Replies: 7
    Last Post: 11-18-2010, 08:43 PM
  5. ECMSpy With Windows 7 - Datalogging Issues
    By CBi in forum General Motorcycle Chat
    Replies: 2
    Last Post: 07-25-2010, 07:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •