Results 1 to 7 of 7

Thread: 04' xb12s no second gear?

  1. #1
    Junior Member
    Join Date
    Sep 2012
    Posts
    4
    Picked up this bike from a kid that layed it down. He cracked the primary, then drove it never noticeing the trail of oil. It drained the primary and trans, then melted the tensioner, and threw the primary chain. Buell wanted $3,800 to fix it, so I picked it up for a song. I hit eBay and put it back together for $200. Runs fine, but I can't get into 2nd. If its off, idling, or driving, I can't get there. I have adjusted the clutch to speck and around. Posibly the detent is bent, or in the trans. I have found it once, but I had to shif at the rev limiter. Not great for riding in the city... This is my first Buell, and it does have 30k on it. Any thoughts befor I tear into my first trans. I don't want to miss something simple and waist time and money. Thanks

  2. #2
    Senior Member
    Join Date
    Jul 2011
    Posts
    512
    Does it go up to third? If it still hits first and third then you may be looking at a blown gear. The shift fork for second is also for first so your fork may be good. It could of also blown the shift dog for engaging second. If it dumped the primary oil then he ran the trans with no oil either since it gets oil from the primary through a feed hole below the clutch. Sounds like you are going to have to crack the case and look at the trans. It's not to bad. I put it all three shift forks, shift shafts, and a new shift cam and with a full engine gasket set was about 300 doing it myself. If you get into gears may be a little higher but I have seen full trans sets for 200 or sometimes less on ebay so if shouldn't be to bad. Just know that the 04 will be different then 06+ I believe because they switched from straight gears to angled. If you get the whole assembly you may be able to switch to the newer style but I'm not entirely sure on that so don't quote me.

  3. #3
    Senior Member
    Join Date
    Aug 2010
    Posts
    2,135
    Just had an issue with my bike not going into second gear. Took it to the dealer expecting the worst and was totally surprised by what they found. The bolt that goes thru the shifter has a plastic sleeve/spacer in the bolt opening and it had come apart and the part that broke off was between the shifter and primary case causing it not to go into gear. I was relieved it was something small but it may be worth a look on yours also.

  4. #4
    Junior Member
    Join Date
    Sep 2012
    Posts
    4
    @vance580

    Yep, I get all gears except 2nd... Do you have to split the engine cases to get to the trans? Or just the primary cover and trans cover, if there is one, I haven't pulled anything off that side yet.

  5. #5
    Senior Member
    Join Date
    Jul 2011
    Posts
    512
    You have to split the case. The XB does not have a trap door so there is no way to access the trans except by splitting the case. It's a pretty big job but you can save a lot doing it yourself. I'd split the case and see exactly what it broken and go from there on what would be the best plan. Here is the link to my rebuild. Let us know if you tackle it and what you find if you do. Where are you located?
    Rebuild

  6. #6
    Junior Member
    Join Date
    Sep 2012
    Posts
    4
    I am located in Los Angeles. Damn, I didn't want to go through the hassle of splitting.

  7. #7
    Senior Member
    Join Date
    Jul 2011
    Posts
    512
    It's not too bad just take your time and set everything up how you took it apart so you don't loose anything and it should go pretty smoothly. Since it has 30k on it if you pick up the full engine gasket set you can get some fresh gaskets on her. Clean up all the carbon and it will run like a brand new bike. If you need any help or get stuck post up and I'll try to help best I can online.



Similar Threads

  1. FS: 2008 XB12S instrutment cluster with gear indicator
    By OverRev in forum Buell Parts for Sale
    Replies: 9
    Last Post: 04-25-2015, 10:40 PM
  2. Replies: 1
    Last Post: 04-30-2014, 09:48 PM
  3. 04' xb12s no second gear?
    By TheCaptain in forum Troubleshooting
    Replies: 0
    Last Post: 09-29-2012, 07:19 PM
  4. 2008 xb12s stutter idle and first gear take off
    By chelch in forum Buell Lightning XB12S, XB12Ss, CityX, XB12Scg
    Replies: 7
    Last Post: 07-16-2012, 06:52 PM
  5. Changing out the oil pump gear for the new design gear
    By turbines in forum Troubleshooting
    Replies: 3
    Last Post: 10-04-2010, 10:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •