Results 1 to 4 of 4

Thread: Fuel pump issues turning on and off

  1. #1
    Junior Member
    Join Date
    Jul 2014
    Posts
    26
    I just installed a different wiring harness in my '07 xb9sx and now after turning on the ignition and setting the bike to run the fuel pump kicks on and then off like normal but when I barley turn the handlebars the fuel pump runs again. Does any one know where I should start looking to find what ever is shorting out or if that the problem?

  2. #2
    Senior Member rchuff's Avatar
    Join Date
    Apr 2012
    Location
    Willow Grove, Pa
    Posts
    1,995
    Look around the steering neck at harness, mite have a bad wire there.(broken wire)

  3. #3
    Senior Member 08herobolt's Avatar
    Join Date
    Feb 2013
    Location
    Saginaw, MI
    Posts
    547
    Agreed. Sounds like a connection issue. Did you take anything off or do any repairs? You may have pinched a wire.

  4. #4
    Junior Member
    Join Date
    Dec 2014
    Posts
    18
    Have you tried to go to the guy who like normally checks the bikes



Similar Threads

  1. Fuel Pump Issues
    By HooliKen in forum Buell Ulysses XB12x
    Replies: 2
    Last Post: 11-01-2013, 05:42 PM
  2. Fuel Pump?
    By Blastonia in forum Buell Lightning XB12S, XB12Ss, CityX, XB12Scg
    Replies: 8
    Last Post: 04-27-2012, 09:09 AM
  3. Replies: 10
    Last Post: 03-16-2012, 06:48 AM
  4. where to get fuel pump strainer and fuel filter
    By Draxsonimy in forum Buell Lightning XB12S, XB12Ss, CityX, XB12Scg
    Replies: 3
    Last Post: 03-03-2012, 02:52 PM
  5. BAD FUEL PUMP?
    By IMKRL in forum Buell Lightning XB12S, XB12Ss, CityX, XB12Scg
    Replies: 10
    Last Post: 06-25-2011, 05:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •