Results 1 to 3 of 3

Thread: NRHS 540 cams

  1. #1
    Senior Member Chicknstripn's Avatar
    Join Date
    Aug 2014
    Location
    High Point, NC
    Posts
    2,144
    Anyone have a picture of these correctly installed in their gear case? I had one but I must have deleted it.
    I know I have them arranged correctly from right to left 1,2,3,4. All the timing marks line up.
    I just want some extra assurance that they're correct.
    I buttoned up the gear case cover already and didn't take a picture prior to doing so.
    I just woke up this morning with that uneasy feeling that if something can go wrong, it will go wrong.
    Thanks

  2. #2
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,845
    If you are unsure, rotate the engine by HAND and see if there is any clearance issues first.

  3. #3
    Senior Member Chicknstripn's Avatar
    Join Date
    Aug 2014
    Location
    High Point, NC
    Posts
    2,144
    Rotating the engine everything seems to work as it should.
    No binding and timing marks line back up after a complete cycle.
    So, I think I was being pariniod for no reason.
    Thanks for the response.
    Now could anyone tell me what on earth might make a loud popping noise while torquing a transmission nut? I was setting the torque prior to installing the diaphragm spring and pressure plat and heard a loud pop. Was much louding then the click of the torque wrench but the same metallic type sound.
    I'm hoping a wash was hung up on a spline or something cause nothing looks broken and everything rotates and shifts as it should



Similar Threads

  1. NRHS Stage 2 for 07 XB12R
    By cjmech in forum Race Kits
    Replies: 24
    Last Post: 11-14-2018, 08:55 AM
  2. Cams
    By antivenom in forum Buell Lightning XB12S, XB12Ss, CityX, XB12Scg
    Replies: 9
    Last Post: 10-08-2012, 02:36 PM
  3. wtb cams
    By wolfo68 in forum Buell Parts for Sale
    Replies: 5
    Last Post: 06-07-2011, 05:20 PM
  4. NRHS 1050 kit
    By bobaganoosh in forum Buell aftermarket parts
    Replies: 16
    Last Post: 04-02-2011, 05:06 PM
  5. Need Help with my Cams. ANYONE!!
    By 07firebolt in forum Troubleshooting
    Replies: 13
    Last Post: 05-01-2010, 02:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •