Page 1 of 14 12311 ... LastLast
Results 1 to 10 of 131

Thread: Want to buy IAC

  1. #1
    Senior Member AZmidget91's Avatar
    Join Date
    Dec 2014
    Posts
    1,664
    Looking for an IAC for my 08 XB12SCG

    IAC-Idle Air Control

    Only bike 08-10 had IAC's

    They are $155 from Harley new, there is a complete throttle body on eBay for $149, I have an offer submitted on right now.

    That being said I would buy a complete throttle body, if you don't want to part out the TB.

  2. #2
    Senior Member thrstrmech's Avatar
    Join Date
    Jul 2011
    Location
    Arizona
    Posts
    5,354
    what's the part number?

  3. #3

  4. #4
    Senior Member Shawns's Avatar
    Join Date
    Jul 2013
    Posts
    904
    Pop it off and check your auto local parts store. I found my IAT sensor at an Autozone.

  5. #5
    Senior Member AZmidget91's Avatar
    Join Date
    Dec 2014
    Posts
    1,664
    I'll give it a try, but I highly doubt it will cross reference, it's pretty small for a car, compared to a tps or iat that is just a sensor.

  6. #6
    Senior Member thrstrmech's Avatar
    Join Date
    Jul 2011
    Location
    Arizona
    Posts
    5,354
    autozone has several models, may find a cross over for it...anything stamped on the original, brand and or number?

  7. #7
    Senior Member AZmidget91's Avatar
    Join Date
    Dec 2014
    Posts
    1,664
    Here is the IAC, Sonceboz Swiss made 90-518 1437



    I found a thread in a vrod forum with a pic of their IAC and is very similar, not quite exact though, but they said to ohm the outer pins and inner pins and should be about 50 and they were. If I turn the ignition on with it out of the TB but connected, it moves, and you can tell it does when mounted too.

    Next I check for a short in the wiring, nothing.

    The IAC is directly controlled from the ECU, no external grounds, all 4 wires go from the ECU to the IAC. There was some corrosion in the ECU connector, I haven't cleaned that out yet, didn't want to look for my electrical cleaner in my shed.

    Here is the wierd part, the wires are in the correct spot in the ECU but they are not on the IAC side, is it common for the service manual to have an error like that? It obviously worked fine before.

    Put it all back together and started it, it was a little better, but the IAC CEL still came on and still didn't idle all too well. Once the CEL came on it idled better, which is what it has been doing and why I'm looking into it. Although the CEL is new.

    As far as I got today, got the wheels off for powder coat tomorrow morning, and won't be able to work on it for a while.

  8. #8
    Senior Member thrstrmech's Avatar
    Join Date
    Jul 2011
    Location
    Arizona
    Posts
    5,354
    found this on Badweb here don't know if this helps, thought maybe a cleaning like this guy did might help

    best I could find, it's a Sonceboz 7217 series linear actuator, can't find a cross reference for the part number

  9. #9
    Senior Member AZmidget91's Avatar
    Join Date
    Dec 2014
    Posts
    1,664
    Yeah, I pulled the TB off last weekend to replace the intake seals, and cleaned everything while it was off. That's when I started to get the CEL was after cleaning everything.

  10. #10
    Senior Member
    Join Date
    Sep 2010
    Posts
    4,403
    Buy from newcastle, from a normal dealership they were 177 plus taxes

    I just bough one because I couldn't find one and didn't want to wait.
    Couldn't find a valid cross reference



Page 1 of 14 12311 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •