Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Brake light not coming on when using rear brake

  1. #1
    Senior Member
    Join Date
    Mar 2015
    Location
    California
    Posts
    417

    Brake light not coming on when using rear brake

    My brake light does not come on when I use the rear brake but works fine with front brake. My first thought is the rear brake switch needs replacing, but before I buy a new one, are there other possible reasons for it not working?

  2. #2
    Senior Member neilrl79's Avatar
    Join Date
    Feb 2012
    Location
    Cecil County, Maryland
    Posts
    1,234
    Well it could be in the wiring between the switch and the light. You could do a continuity test to be sure before you spend some money on a new switch.

  3. #3
    Senior Member Chicknstripn's Avatar
    Join Date
    Aug 2014
    Location
    High Point, NC
    Posts
    2,144
    I have my money on the rear brake switch.
    But definitely do a continuity/voltage test with a multi meter before you buy anything.

  4. #4
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,180
    Key on.

    Unplug the connector at the rear brake light switch and jumper the 2 wires together with a paperclip or something. Don't let it touch metal.

    If the brake light is on now. Replace the switch.

    If not, you should have +12V at BOTH of the terminals on the bottom of the bulb socket with it still jumped (careful not to ground the test lead to the sides of the socket)

    If you do have +12V at both terminals (with the switch jumped) clean the socket and replace the bulb.

    To check wiring:
    At the switch you should have +12V on one wire, and if you put 12V on the wire that doesn't have voltage with the key on you should get a brake light.
    Last edited by Cooter; 03-05-2016 at 08:19 PM.

  5. #5
    Senior Member Chicknstripn's Avatar
    Join Date
    Aug 2014
    Location
    High Point, NC
    Posts
    2,144
    Nice Cooter!
    Anyone having issues with a rear brake switch should be able to trouble shoot it now!
    Good advice man

  6. #6
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,180
    Quote Originally Posted by Chicknstripn View Post
    Nice Cooter!
    Awww, shucks



    That's super nice without the comma

  7. #7
    Senior Member
    Join Date
    Mar 2015
    Location
    California
    Posts
    417
    Thanks guys! Shouldn't be the bulb since the light comes on when I use front brake, so I will check continuity and voltage when I get a chance.

  8. #8
    Senior Member AZmidget91's Avatar
    Join Date
    Dec 2014
    Posts
    1,664
    Mine doesn't work either, but it's probably from not having a switch....

  9. #9
    Senior Member
    Join Date
    Mar 2015
    Location
    California
    Posts
    417
    Quote Originally Posted by AZmidget91 View Post
    Mine doesn't work either, but it's probably from not having a switch....
    Haha. It isn't too horrible for me, since I rarely use the rear brake for actual braking. I mostly use it at stoplights to rest my right hand.

  10. #10
    Senior Member mrlogix's Avatar
    Join Date
    Jul 2011
    Location
    Cincinnati, Ohio
    Posts
    2,561
    the problem you both are experiencing is mis-alignment of your right ankles, please re-calibrate and post pics so we can review and help determine if the problem is resolved.



Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •