Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Brake light not coming on when using rear brake

  1. #11
    Senior Member
    Join Date
    Jul 2013
    Posts
    2,681
    My rear brake light only comes on when I apply allot of pressure. Seriously I can really only get it to turn on after I stop and really step on it...... So try that as well while parked see if it works under lots of pressure!

  2. #12
    Senior Member rchuff's Avatar
    Join Date
    Apr 2012
    Location
    Willow Grove, Pa
    Posts
    2,014
    Just replace banjo fitting at rear master cylinder it is a pressure switch.

  3. #13
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,180
    Quote Originally Posted by djs2k2 View Post
    My rear brake light only comes on when I apply allot of pressure. Seriously I can really only get it to turn on after I stop and really step on it...... So try that as well while parked see if it works under lots of pressure!
    Ya, thats a bad switch for sure. Sometimes you can clean the gunk out of them. It's caused by people that never change their brake fluid. That brown stuff is nasty

  4. #14
    Senior Member
    Join Date
    Mar 2015
    Location
    California
    Posts
    417
    Quote Originally Posted by Cooter View Post
    Key on.

    Unplug the connector at the rear brake light switch and jumper the 2 wires together with a paperclip or something. Don't let it touch metal.

    If the brake light is on now. Replace the switch.

    If not, you should have +12V at BOTH of the terminals on the bottom of the bulb socket with it still jumped (careful not to ground the test lead to the sides of the socket)

    If you do have +12V at both terminals (with the switch jumped) clean the socket and replace the bulb.

    To check wiring:
    At the switch you should have +12V on one wire, and if you put 12V on the wire that doesn't have voltage with the key on you should get a brake light.
    Did step 1 and light came on... Ordered a new switch :P

  5. #15
    Senior Member
    Join Date
    Mar 2015
    Location
    California
    Posts
    417
    It was a bad switch. Swapped out the switch and it is fine now.

  6. #16
    Junior Member
    Join Date
    Nov 2014
    Location
    Orangevale CA
    Posts
    11
    I own a 2004XB12 an had the same thing-B light works off front Lever- Bought new switch and all was good except the price. I ride every day so waiting was not an option for me.



Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •