Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Lots of issues

  1. #1

    Question Lots of issues

    I am an old rider (50 years) but a new Buell owner. Something I had always wanted and finally allowed myself. I live in an area of SC where they are very scarce and certainly no one here works on them. I picked up a seemingly well maintained (visually) 07 Uly X model with all luggage and enormous knobbies and rode it home. It died three times on the 70 mile trip with the CEL coming on first then nothing. Each time I had to wait for awhile with the seat off for it to restart.

    As of the two week mark, I have moved the ECM per forum posts to everywhere the short wiring will allow, insulated with excerise mat foam, cut out part of the seat pan, made and tried numerous brackets but I cannot get more than a few miles from home now without the same problem. Today it just died without warning or the CEL coming on and would not restart until it cooled down (I think).

    I have already put a ton of money in this with road tires, RSS for heat and replacement fluids and filters and really do like the feel of the bike, but I cannot count on it not stranding me over and over. I am open to ideas and suggestions from those with some experience.
    This seems it is going to be a very expensive and unreliable hobby at this point, but I am guessing it is due to a lack of maintenance rather than the bike. I have had many HD's and never been left on the side of the road.

    Thanks to all.

    Forest
    Last edited by Forest Bueller; 05-04-2016 at 05:53 PM.

  2. #2
    Member
    Join Date
    Nov 2014
    Location
    Tallahassee
    Posts
    30
    If the ECM is already damaged, moving it around won't help much.

    I have the same bike and installed a plastic block near the front of the ECM, so the seat hits the block instead of the ECM. Try not to get discouraged, the Uly is a great bike when it is running like it should.
    Last edited by RaisinCain; 05-04-2016 at 06:11 PM.

  3. #3
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,688
    Hey Forest. Sounds like the OP screwed ya a bit

    Buells are pretty rock solid, and dead simple to work on, so lets try and fix the one you have.

    From the limited info you've given, I'd bet the ECM isn't even the issue. The easiest test for the ECM is to start it with the seat off, then tap on the ECM housing with a screwdriver handle. If it stalls, well... there ya go. They're about $150.

    If it doesn't, lets diagnose it one system at a time and find where the issue is.

    Does it die every time you ride it? How many miles? Have you noticed any commonalities when it dies? Is it hot out? Low on gas? Short ride? Long ride? At night? Cold bike? Hot bike?

    How does it die? Just shuts off like the switch was turned off? Or sputter then die? How does it run other wise?

    Does it crank fast if you try to start it right way?

    How loud is the fuel pump when you turn the key on?

    Do you have any tools? Can you check for spark when it dies? Fuel pressure?

    Sorry for so many questions, but they all are pertinent until we can narrow down the cause.

  4. #4
    Do the lights in the dash go out when it dies? If so it may be the ignition switch. I have had and heard of others having this issue. You can remove the switch and clean it. The switch is behind everything on the dash. Here is the ignition wiring diagram. ignition circuit.jpg
    Be sure to give us as many details that you see so we can better help you.

  5. #5
    Quote Originally Posted by Cooter View Post
    Hey Forest. Sounds like the OP screwed ya a bit

    The easiest test for the ECM is to start it with the seat off, then tap on the ECM housing with a screwdriver handle. If it stalls, well... there ya go. They're about $150.

    Done this a few times and it does not stall

    If it doesn't, lets diagnose it one system at a time and find where the issue is.

    Does it die every time you ride it?

    Yes,

    How many miles?

    20 miles was the most ridden, but the distance is shortening to perhaps 5 now.

    Have you noticed any commonalities when it dies? Is it hot out?

    It isn't cool in SC, but today was in the 60's early and I got further than normal. When it died I let it sit with seat off and after 10 minutes I was able to return home.


    Low on gas? Short ride?

    Can't get it to run long enough to use any gas from the full tank.

    Long ride?

    Whats that?


    At night? Cold bike? Hot bike?

    Never been out at night yet, but as hot as it gets in 10-15 minutes.

    How does it die? Just shuts off like the switch was turned off? Or sputter then die? How does it run other wise?

    When it does run from cold, it seems to run great. When it had previously shut off the CEL would come on and then it would stall. I could pull in the clutch and restart it again. Now, it just quietly stops with no warning.

    Does it crank fast if you try to start it right way?

    Nope, just the usual HD pause then cranks. Battery is new and in the 13+ range and on a Battery Tender when parked.

    How loud is the fuel pump when you turn the key on?

    Relativily quiet. But, I don't know what is normal

    Do you have any tools? Yes, but not on the side of the road pushing it to a clearing Can you check for spark when it dies? I haven't yet. Fuel pressure? I have opened the cap to see if there is a vacuum but it just restarts when it is ready.

    Sorry for so many questions, but they all are pertinent until we can narrow down the cause.
    No, I am grateful for all inputs above.

    RE: The ECM, I cannot find anything cheaper that $300+ online or eBay. It is the Buell y0152.3ab

  6. #6
    BTW: One odd thing that happens is when I lift the bike off the side stand and the key is off and the Kill Switch is on, the dash guages will swing as though I had just turned the key on, but I haven't yet.

  7. #7
    Hey Firefighter, I honestly haven't looked while trying to get off the road. I will make the effort to notice tomorrow.

  8. #8
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,688
    Quote Originally Posted by Forest Bueller View Post
    BTW: One odd thing that happens is when I lift the bike off the side stand and the key is off and the Kill Switch is on, the dash guages will swing as though I had just turned the key on, but I haven't yet.
    That's a big clue right there Forest...

    These are known to have issues with the wiring harness right around the steering neck. The dash gauges swinging is them losing power, then getting power back.

    Go out and start it, swing the handlebars lock to lock, grab what you can of that part of the harness and wiggle. Even take off the front windscreen and wiggle wires in there around the ignition switch. My bet is that it dies, and needs some minor wiring fix right there.

  9. #9
    Just remembered another detail. When I do turn on the key, the headlights will brighten and dim a few times on their own. Since I have never seen another Buell up close, I don't know if this is Normal or Not. Seemed odd, but it's all Greek to me.

  10. #10
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,688
    Not normal. Check the wiring.



Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •