Results 1 to 5 of 5

Thread: Electrical problem?

  1. #1
    Member
    Join Date
    Jun 2014
    Location
    Clovis, CA
    Posts
    87

    Electrical problem?

    Alright boys I've got an issue... the main issue is my headlights... my low beam tends to like to flicker a bit and both high and lows like to fade in and out. Dim to bright but never off... and it's somewhat in sync with when I WOT and let off as well but like I said it's only somewhat in sync to that. Cuz I'll be cruising and the lights will dim and gradually get back to bright. I've noticed this also in my gauges but not nearly as bad as the headlights. I have a brand spankin new battery and the only thing I can think of off the top of my head is ad wires?

  2. #2
    Senior Member mrlogix's Avatar
    Join Date
    Jul 2011
    Location
    Cincinnati, Ohio
    Posts
    2,561
    check grounds (yes, plural) dimming and flickering can be from load changes (load on the stator) aggravated by loose or corroded grounds. other than that, voltage regulator, connectors, frayed wires, etc., etc.

  3. #3
    Member
    Join Date
    Jun 2014
    Location
    Clovis, CA
    Posts
    87
    So as I expected I'll be on a scavenger hunt for a little bit... lol

  4. #4
    Senior Member
    Join Date
    Sep 2010
    Posts
    2,194
    +1 to Mr. Logix

  5. #5
    Inactive
    Join Date
    Feb 2011
    Location
    AmishLand, PA.
    Posts
    7,526
    here.....

    http://www.buellxb.com/forum/showthr...y-and-Solution



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •