Results 1 to 4 of 4

Thread: Buell Blast hard to start

  1. #1
    Senior Member
    Join Date
    Nov 2013
    Posts
    139

    Buell Blast hard to start

    Hey guys,

    my wife has a 2001 Buell Blast. Once it's warmed up it runs perfectly, but when cold it's very difficult to start. As in I can sometimes get it to start if I crank it for a minute or so (ridiculous!). I can start it instantly with starter fluid, but I try not to use that.

    So far to fix it I've changed jetting to 45/170, installed a super-boot, changed the spark plug, and checked the float level. What else could it be? My thought is auto-enrichener. Any idea where I can get one for cheap?

  2. #2
    Senior Member
    Join Date
    Jul 2009
    Location
    la harpe, il
    Posts
    672
    the carb could use a good cleaning/ rebuild. i have the same issue with mine. just haven't had time to mess with it. if you are looking for the auto enricher try harley shops like new castle, surdyke, st. paul, heartland harley. or ebay. paul pud parts a lot of bikes. he may have one.

  3. #3
    Senior Member
    Join Date
    Jan 2009
    Location
    SF East Bay
    Posts
    1,110
    Do not "clean" the carb, get that damn thought out of your head.

    Tune your carb with these videos:
    https://www.youtube.com/playlist?lis...K1JbF6ICqCfkxD

  4. #4
    Senior Member
    Join Date
    Nov 2013
    Posts
    139
    Quote Originally Posted by jetlee View Post
    Do not "clean" the carb, get that damn thought out of your head.

    Tune your carb with these videos:
    https://www.youtube.com/playlist?lis...K1JbF6ICqCfkxD
    Hey man, I sent you a message on Buellriders the other day, but I'll reply here as well:

    "It appears my AE is not functioning, I took the top off my carb and switched the ignition on (which from what I understand should start heating the AE and closing the plunger). I watched it for a couple minutes and it never budged so I"m assuming my AE is bad. Is there anything else between the AE and battery (as in, could a fuse be blown?) or do I just need to replace the AE?"



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •