Results 1 to 8 of 8

Thread: Ecm Troubles

  1. #1
    Junior Member
    Join Date
    Jul 2017
    Location
    North Pole, Alaska
    Posts
    8

    Ecm Troubles

    I have a 2000 X1 that needs some ecm work. I have the ecm spy but my ecm is not one on the supported list. BFIUS1. I am to the point where they want $70 and I don't even know if it will work and I don't know what to select for an ecm. I am new to this whole thing. My bike has a k&n air filter and a Vance and Hines exhaust. Any help would be appreciated.

  2. #2
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    7,076
    Back up.
    What is "ecm work" and why do you think you need it?

  3. #3
    Junior Member
    Join Date
    Jul 2017
    Location
    North Pole, Alaska
    Posts
    8
    The bike used to have a power commander but it wasn't working properly. Would only run on one cylinder. So I cut that thing out and it runs lean now because of the air filter and exhaust being aftermarket. I just need to upload a richer map so I don't burn it up. It also hiccups a lot anytime I am below 3500 rpms. I have the cable I need, I just didn't know what to select on the ecm spy website for ecm. The label on my ecm is not listed on their website for comparable ecms. I have been reading a lot of the threads here and it seems like y'all have a lot of experience with the program.

  4. #4
    Junior Member
    Join Date
    Jul 2017
    Location
    North Pole, Alaska
    Posts
    8
    Supported ecms, not comparable. Sorry

  5. #5
    Junior Member
    Join Date
    Jul 2017
    Location
    North Pole, Alaska
    Posts
    8
    So, I am almost positive the ecm I have is the BUEJA, even though it's not what it says on the actual ecm. I am just waiting for ecmspy to email me back with the actual program to run. I have sent the money to their charity of choice, is there something else I need to do?

  6. #6
    Junior Member
    Join Date
    Jul 2017
    Location
    North Pole, Alaska
    Posts
    8
    I have also noticed that the headlight is kind of dim and the horn kind of quiet, I think the voltage regulator or the stator is fading. I will have to test it with the multimeter and see what's up. Does anyone know if that will cause a backfire only at lower rpms?

  7. #7
    Junior Member
    Join Date
    Jul 2017
    Location
    North Pole, Alaska
    Posts
    8
    Does anyone know if ecmspy is still active? I have got no response from those guys. Been a few days.

  8. #8
    Junior Member
    Join Date
    Aug 2017
    Posts
    2
    I'm having similar
    Problems and offered the cable as well
    And I'm
    Not computer savvy enough to figure it out is there any one that can help please I have no
    Transportation besides this and I'm
    Now out of money and work
    I 4055682168



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •