Results 1 to 10 of 10

Thread: Dumb Dumb

  1. #1
    Junior Member
    Join Date
    Oct 2015
    Posts
    8

    Angry Dumb Dumb

    So yesterday was one of those days.. hadn't had the time or dinero to get my 2005 Buell XB9 working so I tried to get her running and zip her over to a mechanic. First tried to jump start the batter but couldn't. Called AAA, they came, attached their jumper cables and got her running but every time he disconnected his cable/jumper, she'd die. Battery needed replacing. Okay Mr. AAA, thanks anyway. Called Pep Boys, said they had a battery, went and picked it up... I put it in, connected the cables, and nada!!! Oh wait.. the positive and negative are on opposite sides. ****! I connected the pos+ neg- backwards!!! NOOOOOOOO!!!!

    So I got the correct battery, put it in, and... Nada. Nothing. Not a peep. So, how *ucked am I? Is this an easy fix or has major damage been done? I'm no gear-head, obviously, but is there specific fuses that blew or does it go deeper than that? What's my first course of action? And yes, I already punched myself square in the face.. so at least that step has already been taken care of.

    Thank you for the advice in advance!
    Last edited by Sumosurfer; 07-19-2017 at 05:06 PM.

  2. #2
    Senior Member Chicknstripn's Avatar
    Join Date
    Aug 2014
    Location
    High Point, NC
    Posts
    2,144
    www.buellmods.com
    Go to the above sight and download a service manual.
    Then do a little research in said service manual before you attempt any other repairs.

    Your firebolt has a fuse box to the right of your dashboard/front fairing stay. The fuses are labeled on the box. Pop that open and start checking the fuses. There is also a battery fuse in the rear tailsection left of the battery. Check that as well. once you've insured all the fuses are good you'll have to do the same with the relays. Those are found in an identical looking box as the fuses on the opposite side or the front fairing as the fuses.
    Report back what you discover
    And good luck!

  3. #3
    Junior Member
    Join Date
    Oct 2015
    Posts
    8
    Thanks for the advice, man! Much appreciated!

  4. #4
    Inactive
    Join Date
    Feb 2011
    Location
    AmishLand, PA.
    Posts
    7,526
    ^^^^ spot on carlos as usual. the first thing to pop when crossing the cables is the diode fuse. it's the blade fuse in your box with directional arrow on it that always faces to the right/brake pedal side of the bike. if you did no harm to your ecm consider yourself fortunate.

  5. #5
    Senior Member GregoXB's Avatar
    Join Date
    Feb 2012
    Posts
    1,516
    I feel this guy may want to take his bike to a mechanic.... No offense

  6. #6
    Junior Member
    Join Date
    Oct 2015
    Posts
    8
    No offense taken and couldn't agree more! Cheers

  7. #7
    Senior Member
    Join Date
    Mar 2015
    Location
    Forest Grove, OR
    Posts
    527
    Man, that sucks. I'd also recommend not punching yourself in the face again...I know I have a really hard time thinking clearly with a broken nose. Good luck, Sumosurfer! And, yes...report back what you find out.

  8. #8
    I've done this before....it blew one of the relays...easy fix....can get them at local parts store....ford ac relay

  9. #9
    Junior Member
    Join Date
    Oct 2015
    Posts
    8
    Thanks man!! LOL! Once was enough so no more punching myself!

  10. #10
    Junior Member
    Join Date
    Oct 2015
    Posts
    8
    That's a relief to hear OntarioBueller!! Thanks man!



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •