Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Fuel pump keeps running....04 firebolt. Help!

  1. #1
    Senior Member
    Join Date
    May 2014
    Posts
    173

    Fuel pump keeps running....04 firebolt. Help!

    I know it's in here somewhere. Iremember reading it a while back, but I can't find it. Anyway sounds like my fuelpump (guessing the primer) keeps running the whole time the bike is running. Any help would be hugely appreciated. My only bike n i love her and wanna keep racking up the miles. Thank you in advance for any help or guidance

  2. #2
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,048
    So...
    The "fuelpump (guessing the primer) keeps running the whole time the bike is running"

    Thats good? The fuel pump needs to pump...fuel... otherwise the bike won't run.

    Whats a "primer"?

  3. #3
    Senior Member midway's Avatar
    Join Date
    Jan 2016
    Posts
    361
    Quote Originally Posted by tomahawk1976 View Post
    Anyway sounds like my fuelpump (guessing the primer) keeps running the whole time the bike is running.
    This happend to me... keeps whining after the engine light goes out. There are those in here who can tell you exactly which part to replace on the pump but I just replaced the entire pump. Now it's quiet as a mouse. You know your bike, that sounds not right... even though it still runs fine.

    You will have to let the swing arm down by disconnecting the shock, don't stress the brake line so remove the rear wheel and callipers first. I'm not a Pro maybe get your SM out or wait for lunatic to set us straight Lots of fuel left in there even after you think you drained it all (don't be smoking). The unit itself gets a little squirrely going in so take care to watch the twists and angles as you take it out. I would say the skill level rating for this job is.... low.

    You can get a new one for what this guy is asking on ebay http://www.ebay.com/itm/03-BUELL-FIR...FWBZkA&vxp=mtr

    Go see Lance at St. Paul Harley or get your part number and try New Castle
    https://shop.newcastlehd.com/
    Last edited by midway; 07-03-2017 at 05:43 AM.

  4. #4
    Senior Member Chicknstripn's Avatar
    Join Date
    Aug 2014
    Location
    High Point, NC
    Posts
    2,144
    Pull your pump and check the wiring. I'm 100% positive you'll find a spot where the fuel pump wiring has rubbed bare against the body of the fuel pump assembly. Repair the wiring and the pump will prime normally.
    While you have the pump out it's a good idea to replace the fuel filter and filter screen/sock at the base of the pump.
    Google search, "Buell xb fuel pump rebuild" and I'm sure you'll find all the info you need.

  5. #5
    Senior Member midway's Avatar
    Join Date
    Jan 2016
    Posts
    361
    Quote Originally Posted by Chicknstripn View Post
    the fuel pump wiring has rubbed bare against the body of the fuel pump assembly. Repair the wiring and the pump will prime normally.
    Well ****... the poor man's fix. I should have done that

  6. #6

  7. #7
    Senior Member Chicknstripn's Avatar
    Join Date
    Aug 2014
    Location
    High Point, NC
    Posts
    2,144
    Quote Originally Posted by Silverrider View Post
    Silver, have you tried this one? That's great if the actual pump needs replacing. 99% of the time when the pump continually primes its an issue with one of the wires shorting out on the pump body due to the wire insulation rubbing away.
    My fuel pump continuously primed for about a year before I fixed it. I replaced the filters while I was at it and that was about 4 or 5 years ago. Pump is still going strong.
    Oh, AND I REUSED MY fuel pump O Rings! 43k on the bike and the original fuel pump is still working.

  8. #8
    Senior Member midway's Avatar
    Join Date
    Jan 2016
    Posts
    361
    Quote Originally Posted by Silverrider View Post
    That's excellent! Hey do you think that will rebuild the whiney one I pulled from a 06 XB9R firebolt? For 30 bucks I'd like to fix and keep a backup around.
    Last edited by midway; 07-03-2017 at 03:34 PM.

  9. #9
    Senior Member Silverrider's Avatar
    Join Date
    Sep 2016
    Posts
    2,722
    Quote Originally Posted by Chicknstripn View Post
    Silver, have you tried this one? That's great if the actual pump needs replacing. 99% of the time when the pump continually primes its an issue with one of the wires shorting out on the pump body due to the wire insulation rubbing away.
    My fuel pump continuously primed for about a year before I fixed it. I replaced the filters while I was at it and that was about 4 or 5 years ago. Pump is still going strong.
    Oh, AND I REUSED MY fuel pump O Rings! 43k on the bike and the original fuel pump is still working.
    Yes, Works great no issues.

  10. #10
    Senior Member Silverrider's Avatar
    Join Date
    Sep 2016
    Posts
    2,722
    Quote Originally Posted by midway View Post
    That's excellent! Hey do you think that will rebuild the whiney one I pulled from a 06 XB9R firebolt? For 30 bucks I'd like to fix and keep a backup around.
    http://www.ebay.com/itm/INTANK-FUEL-...YAAOSw-0xYeIzj

    I have not used this one .



Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •