Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Clicking noise when tryingn to start

  1. #1
    Junior Member
    Join Date
    Apr 2018
    Posts
    5

    Clicking noise when tryingn to start

    Harley just replaced a brand new battery in my bike. I rode it home just fine, started about five times today while i was detailing it and then i went to dinner and tried to start it and just got a bunch of clicking noises. Headlights are strong, battery is brand new, cleaned all then connections, checked the fuse and everything looks normal. Any ideas on what my next steps should be? Im adraid to take it back to them becaue i just paid $442 for them to reconnect my rear header cuz the nuts fell off and replace the battery. I just feel like theyre gonna take me for more money and hoping i can fix this myself please help.

  2. #2
    Senior Member lunaticfringe's Avatar
    Join Date
    Feb 2011
    Location
    AmishLand, PA.
    Posts
    7,267
    you asked this precise question in your header nuts thread. asking 1X suffices. fresh thread for same question is clutter on here.

    do you own a multi-meter or simple DC volt meter and know how to use one? if so i'll provide the testing procedure and solutions. if not then take it back to the dealer.

  3. #3
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    1,445
    There are YouTube videos on how to use a multimeter. Fully charge up the battery then take it to a auto zone or Advanced auto parts store and have them check the battery, people have gotten brand new batteries that were defective. Make sure to clean off all of the grounds on the bike, no matter how clean they look.

  4. #4
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    5,784
    Sounds like starting it five times while detailing it drained the charge on the battery. Test for resting voltage, and cranking voltage. All in the free Buell service manual download at Buellmods.com or Buelltooth.com

  5. #5
    Senior Member Silverrider's Avatar
    Join Date
    Sep 2016
    Posts
    2,160
    Jump start it !!! With cables

  6. #6
    Senior Member TPEHAK's Avatar
    Join Date
    May 2014
    Location
    Seattle
    Posts
    1,636
    Bad connection between sit rails and frame

    https://youtu.be/m-oMwQx2IWo

    https://youtu.be/l6q5awGrJq8

  7. #7
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    5,784
    There are hundreds of possibilities of whats wrong with the bike. Only proper diagnosis will find the problem quickly, and cheaply. It's simple and easy.



    Unless you know exactly whats wrong because you have TPEHAK's crystal balls!

  8. #8
    Senior Member
    Join Date
    Mar 2015
    Location
    Phoenix, AZ
    Posts
    809
    Quote Originally Posted by cooter View Post
    unless you know exactly whats wrong because you have tpehak's 3d printed crystal balls:d!:d
    fixed it for you

  9. #9
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    1,445
    Wait a minute !, How does Cooter know that Tbag's balls are crystal ?

  10. #10
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    5,784
    Because I broke them with my giant Brass ones.



Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •