Results 1 to 3 of 3

Thread: Quick questions on new to me Buell!

  1. #1
    Junior Member
    Join Date
    May 2018
    Location
    Ann Arbor, MI
    Posts
    21

    Quick questions on new to me Buell!

    Guys! I just got my first Buell!! Iím going to post a thread on my adventure... but first some things I noticed on my 700miles home..
    Itís an 08 XB12SS with 8k miles...
    -Shift effort... The gearbox is very precise but the effort to upshift left a bruise on my foot... I upshifted with my heel the last day because it hurt so bad. Is this normal? Ouch!
    - Mine has the 25th Anniversary plaque on the bars... anyway to confirm it is?
    - The oil light came on at idle briefly, oil level is good. Tried playing with the wire... Decided to keep going, and the oil light never came back on, weird electrical thing?
    After 700miles those were my only Qís itís a lovely bike!!!

  2. #2
    Senior Member midway's Avatar
    Join Date
    Jan 2016
    Posts
    336
    Congrats for the confidence in a used unfamiliar motorbike to carry you on a 700 hundred mile road trip. I guess i'm just not there yet
    I suspect you are riding with a soft toe shoe and you've some conditioning to do. Proper riding boot or a 'Motorcycle Gear Shifter Shoe Boot Protector' would have been a good idea for a while. Can't speculate on the oil light sensitivity but you can check circulation if nervous by viewing through the oil fill port with the bike on the side stand.

    Good luck and I'll read about your travels.

  3. #3
    Senior Member lunaticfringe's Avatar
    Join Date
    Feb 2011
    Location
    AmishLand, PA.
    Posts
    7,019
    Shift effort... The gearbox is very precise but the effort to upshift left a bruise on my foot... I upshifted with my heel the last day because it hurt so bad. Is this normal? Ouch!

    can be improved upon with a few adjustments, fluid change, buell/sportster type shifting procedure....and boots like rob
    mentioned.

    Mine has the 25th Anniversary plaque on the bars... anyway to confirm it is?
    that is correct. all 2008's are 25th anniversary models.

    The oil light came on at idle briefly, oil level is good. Tried playing with the wire... Decided to keep going, and the oil light never came back on, weird electrical thing?

    it might be filled with 15wt.-40. in higher temps that oil will occasionally trigger the oil pressure light at idle.
    as time permits go with a full fluid change and 20wt-50 motor oil. in these summer temps that's what you want to run. should put an end to the occasional oil-pressure light blip.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •