Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Very noticeable flat-spot/sputtering in power-band between 4-4.5krpm

  1. #21
    Senior Member outthere's Avatar
    Join Date
    Jun 2018
    Posts
    493
    Have you done the breather mod? Looks to me like you may have a bit of blow by on the rear cylinder.

  2. #22
    Junior Member
    Join Date
    Aug 2018
    Posts
    18
    Do believe the strong gas smell is from the tank getting very hot and venting fumes out the vent line. Mine had enough gas condensing in the vent line to start dripping in the garage. Strangely both happened in the same day.

    I have the race mapping with a baro to adjust AFV and have my AFV set to 100. I've since reflashed the mapping and set my fan limits lower to try to maintain a cooler temp. Haven't rode it around yet but it idles fine.

  3. #23
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,048
    Leaking injector o-rings will either suck air (lean) or leak fuel outside the intake but will not cause a rich condition.

    Resetting the AFV to 100 is simply a diagnostic step, no need to disable CL. I'm curious if it runs better.

    Both hesitation and bucking are not normal, a slightly higher cold idle is normal, a fuel smell can be normal for a Buell also.

    O2 sensor is cheap. Support the rear of the bike, remove rear shock and let swing arm hang, remove fan, bam you're there. Get a 7/8" crowsfoot or specialty socket for it.

    The rest of the procedures (like replacing injectors) hard to spell out here, but they are in the service manual. You can get it for free at Buellmods.com or the Buelltooth.com site you bought your dongle from.
    Last edited by Cooter; 05-24-2020 at 03:23 AM.

  4. #24
    Junior Member Polishblood's Avatar
    Join Date
    Aug 2017
    Location
    Bridgewater, New Jersey
    Posts
    21
    Quote Originally Posted by outthere View Post
    Have you done the breather mod? Looks to me like you may have a bit of blow by on the rear cylinder.
    No, I do not have the breather mod. Yea, rear plug looks suspicious.

  5. #25
    Junior Member Polishblood's Avatar
    Join Date
    Aug 2017
    Location
    Bridgewater, New Jersey
    Posts
    21
    Set the AFV to 100, along with the minimum and maximum, and hesitation was 110% gone. Bike rode much much smoother through closed loop (2-4.5krpm). However, I tried an AFV of 96, 93, 90, and the bike "seemed" to pull the hardest/way more rev happy through closed loop at an AFV of 90 despite having a higher occurrence of the hesitation. The lower the AFV, the higher occurrence of the 4-4.5krpm hesitation.

    I will go ahead and changed the oxygen sensor today. See what happens.

    Question:
    How often does the AFV change? Before changing the AFV to 100 and it dropped from 90% to 85%. Then after playing around with the AFV and putting it back to normal minimum and maximum, AFV reset it self to 90%.
    Last edited by Polishblood; 05-27-2020 at 12:50 PM.

  6. #26
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,048
    A butt-dyno is in incredibly in-accurate machine. Ignore its data completely

    What is the firmware version on your ECM? I have had problems with the AFV re-setting on ignition cycle with BUEZD.

  7. #27
    Junior Member Polishblood's Avatar
    Join Date
    Aug 2017
    Location
    Bridgewater, New Jersey
    Posts
    21
    BUEOD.

    Change the oxygen sensor. No difference. Changed the Fuel Injectors a week ago, 2-3krpm is noticeably smoother, and haven't experienced any hesitation after 100 miles. I will ride again this weekend to confirm the issue is 100% gone. I'll post a picture of the oxygen sensor and explain how I replaced everything. Replacing the injectors, intake seals, and cleaning/polishing everything took me 8 hours but it wasn't as hard as many have stated in previous posts. Then again, I have a lot of different wrenches.

  8. #28
    Junior Member
    Join Date
    Jun 2020
    Posts
    1
    Why is it everyone goes to the dcpr9eix instead of the factory equivalent dcpr8eix heat range ?



Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •