Results 1 to 9 of 9

Thread: Anybody in Portland, Oregon? Need help

  1. #1
    Member
    Join Date
    Oct 2015
    Location
    Wilsonville, Oregon
    Posts
    56

    Anybody in Portland, Oregon? Need help

    Just purchased a super nice 2007 XB12Ss with only 5800 miles. It tends to idle low and dies sometimes, increased the idle but then sometimes it gets stuff at 2K RPM at stops. I read that it probably needs a TPS reset. I have ordered the cable but just in case I wanted to see if anybody here from Portland metro area that knows more about these bikes than I do. I had an XB9S a couple years ago but she was perfect, never an issue. My new bike has Micron exhaust and race ECM, love the machine OMG.

    Thanks for the help and glad to have a Buell again!

    Santiago

  2. #2
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    2,400
    You could also order up a Buelltooth, it works very well with an Android phone. It will also record data when you ride.
    What do you mean " it sometimes gets stuff at 2000 rpm and stops " ?
    Did you check your 77 connector, if not use some dielectric grease on it while it's apart.
    I'm sure the guru's will chime in here and help you out a bit later.

  3. #3
    Member
    Join Date
    Oct 2015
    Location
    Wilsonville, Oregon
    Posts
    56
    Quote Originally Posted by njloco View Post
    You could also order up a Buelltooth, it works very well with an Android phone. It will also record data when you ride.
    What do you mean " it sometimes gets stuff at 2000 rpm and stops " ?
    Did you check your 77 connector, if not use some dielectric grease on it while it's apart.
    I'm sure the guru's will chime in here and help you out a bit later.
    Sorry meant to say it gets stuck at 2000 rpm... so basically I has an idle problem and then after it goes up to temp sometimes it gets stuck at 2000 rpm. Again, I was told a TPS reset and then setting it to 5.1 and then adjust the idle with the screw next to the air dam.

    77 connector? I don't know where that is, can you tell me or show me a picture? Thank you!

  4. #4
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    2,400
    If you google it, a lot of info will come up. I don't think this has anything to do with your problem but it's still good to know about it, this is what I came up with,
    https://www.buellxb.com/forum/showth...ight=connector

    Sounds to me like you have to do a TPS reset and then adjust your idle, let us know how it works out.

  5. #5
    Member
    Join Date
    Oct 2015
    Location
    Wilsonville, Oregon
    Posts
    56
    Quote Originally Posted by njloco View Post
    If you google it, a lot of info will come up. I don't think this has anything to do with your problem but it's still good to know about it, this is what I came up with,
    https://www.buellxb.com/forum/showth...ight=connector

    Sounds to me like you have to do a TPS reset and then adjust your idle, let us know how it works out.
    Yeah sounds like it to me as well based on all the research I've done, I will have the cable tomorrow and ECMSpy and report back.

  6. #6
    Member
    Join Date
    Oct 2015
    Location
    Wilsonville, Oregon
    Posts
    56
    OK crazy story but I ended up buying this bike back, I sold it back in Aug of 2018. I just bought the bike a week and half ago. SAME issue still present. I ended up downloading a fuel map from a guy on the Internet who has the same setup as mine, opened up box with K&N filter and Micron exhaust. I downloaded the map using ECMSpy and after that I did a TPS reset and set the idle once warm and the bike RUNS perfect, finally so HAPPY!

  7. #7
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Posts
    2,389
    That’s a pretty crazy story. I see my old bikes popping up craigslist from time to time. Either way, glad to hear you got it sorted!

  8. #8
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,348
    Theres a nice Ss in OKC for sale right now!

  9. #9
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Posts
    2,389
    Quote Originally Posted by Cooter View Post
    Theres a nice Ss in OKC for sale right now!
    Thank goodness I spent that money... and that I am lazy.

    And smart enough to not look at that ad. (ok maybe not that smart).

    I am smart enough to get my shoes on the correct foot in the morning.

    Plus, I really need to meet up with thrstr this weekend to get him those XB parts.


    Last edited by 34nineteen; 09-18-2020 at 06:00 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •