Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: About to pull the trigger on an 1125CR

  1. #11
    Senior Member pdksh's Avatar
    Join Date
    Nov 2016
    Location
    Ontario
    Posts
    162
    The deal is done, picking it up Monday morning. I would go sooner but I going away for the weekend. The price was FANTASTIC! Enough room to replace the stator and rotor if required. The bike has 22,000 KMS on it (13,000 miles) so I hope it has been already fixed. The first thing I'm going to do is order a stator cover gasket and check if the rotor was drilled and if it still has the HD band-aid. I'll get a couple of miles in before the snow :-)
    Pics to follow!

  2. #12
    Senior Member pdksh's Avatar
    Join Date
    Nov 2016
    Location
    Ontario
    Posts
    162
    Just brought her home. Wow what an ANGRY BIKE! The bike still has the original club-man bars, Ill have to see if I can endure them. I had club-man bars on my old RD350LC 30 years ago! This thing has insane amounts of power, coming from an XB and an X1 - WOW! I'm not 100% sure if the HD fix is installed, I just looked over the wiring under the seat. It's a little bit of a rats nest. Bike appears to be totally original, the PO removed the inner airbox cover, probably to make it sound meaner. Stock exhaust. I'll tear the stator cover off this winter and check for the drilled rotor. Very Happy so far.

    IMG_1578.jpg
    IMG_1577.jpg

  3. #13
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    5,851
    Black lobster looks great!

    I'll always keep a soft spot in my heart for a CR with clubmans.

    However, my wrists couldn't live with the downturn angle and had to go with longer cables and the high bars for any riding farther than 200 miles

    Post a big picture of under the seat, I'll tell you if the 'fix' is there. But really why bother? If it works, you could leave it alone and just pay attention? Theres a voltmeter on the dash. I believe the '08's were OK and it was some of the '09's that had an issue.



Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •