Results 1 to 4 of 4

Thread: Bad O2 Sensor or Intake Seals?

  1. #1

    Bad O2 Sensor or Intake Seals?

    So I picked up a Buelltooth and have been poking around in the ECM. I see the AFV is WAY down at 85.9%. I tried to reset to 100% and go for a good ride. Afterwards, it was again back at 90%. I replaced the spark plugs with NGK Iridiums (DCPR8EIX). The plugs I took out were OEM and black tipped (see pic)

    It seems to bog quite badly especially at low speeds. I'd like to resolve the issue and I done some reading on here that intake seals and/or an 02 sensor could be the issue? For reference it's an 08 Anniversary Edition with 18,600 miles (30,000 kms)

    Any advice from the resident experts?

    MVIMG_20180807_173930.jpg

  2. #2
    Senior Member lunaticfringe's Avatar
    Join Date
    Feb 2011
    Location
    AmishLand, PA.
    Posts
    7,173
    WAY too much fuel being delivered. ecm gurus sure to chime in ref. your AFV values. typically see those values with failing O2 sensor as opposed to failing intake seals. failing ETS also typically prevents the ecm from generating/storing O2 sensor fault code #13. i know virtually nothing about ecm's so go ahead and abuse me and pick apart the above statement.
    here's the inexpensive and easy steps that i do in your situation:
    use your goodies on hand to check stored fault codes and they are here....
    https://www.buellxb.com/forum/showth...ouble-Codes-08

    use this link for easy O2 sensor removal/replace.
    https://www.buellxb.com/forum/showth...r-on-XB-Models

    use this link for O2 cross-overs......remove with either 22mm crows-foot wrench OR 22mm slotted O2 sensor socket. strongly suggest taking your old sensor along if matching up locally. here....
    http://www.badweatherbikers.com/buel...tml?1359770777
    Last edited by lunaticfringe; 08-26-2018 at 12:32 PM.

  3. #3
    Senior Member rchuff's Avatar
    Join Date
    Apr 2012
    Location
    Willow Grove, Pa
    Posts
    1,922
    Like John said way to much fuel. I to would suspect 02 sensor. I would replace with new, reset AFV and go for ride then check and see where you are at.

  4. #4
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    5,586
    The same program you used (ECMDroid) with the Buelltooth you bought will tell you all sorts of info to see if you need a part before you blindly start guessing.

    You can go to the live data screen while its running and check O2 sensor voltages and reaction time to see if you really need one.

    The intake test is a bit more analog. I use a Bernzo-o-matic ($10 torchhead) to direct propane or MAP gas around the intake seals while running to see if the idle changes. You want to test at idle only because thats high vacuum and will show the problem the easiest.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •