Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Check Fuses buell 2008 xb12

  1. #11
    Senior Member rchuff's Avatar
    Join Date
    Apr 2012
    Location
    Willow Grove, Pa
    Posts
    2,018
    Quote Originally Posted by Cooter View Post

    But really, who knows? Electrons are pretty negative little bastards
    So if you don't really know then why did you type the big words if your not 100% sure. Don't really get why you have to be a jerk to this guy and act like a know-it-all. This site had turned into Cooters corner not buell forum. I know a mechanic that works at a h-d dealership and he worked on Buells and had at least 3 that got burned from people hooking up batteries wrong. The dealership was Brian's H-D. God I can't take when someone acts like a know-it-all!!! If this gets me kicked off O'well!!!!
    Last edited by rchuff; 09-22-2018 at 12:40 PM.

  2. #12
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    2,674
    I like Cooter 's corner !
    You got it wrong, John's the know it all, Cooter well, is just Cooter !
    Last edited by njloco; 09-22-2018 at 04:08 AM.

  3. #13
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    2,674
    Take a chill pill, it was totally said in jest, I was giving the last statement it's due, but you and the Cooter do know a lot and, as opposed to others here I think that is a very good thing for the rest of us that you and Cooter are willing to share that with us !

    I still like that saying, Cooter's corner.

    RC, I think you need to lighten up, in Cooter's post, he says he thought he'd have some fun with the OP's yelling question or, did you miss that ?
    Last edited by njloco; 09-22-2018 at 01:36 PM.

  4. #14
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    10,928
    Calm down Ricky. I'm a bit of a smartass, but theres no font for that Like I said, It's just my funny way of telling the OP theres no need for yelling questions

    As for being a "know-it-all"... Just like Lunatic, I never claimed to be anything I'm not. Add 'In my experience' to every one of my posts if that makes you feel better. If you 'know a guy' who's had a different experience, please share it. My comment about electrons was for exactly that reason.

    In my experience

  5. #15
    Senior Member BuellyBagger's Avatar
    Join Date
    Apr 2010
    Location
    Nebraska City, NE
    Posts
    3,692
    Hey fellers... I haven't posted in a while, I know. This definitely isn't the thread I wanted to come back in. Picked up a cheap, basically for parts, but supposedly running lightning today. Unfortunately when I arrived the kid selling it hooked up the battery from his harley to start it for me and of course the posts were backwards. So wish me luck. Going to change relays and fuses and pray the ecm is good. BTW anyone have a cheap ecm for and 09 12ss? Ha. But yeah wanted to post what happens so everyone can see the results.

  6. #16
    Senior Member Barrett's Avatar
    Join Date
    Jun 2020
    Location
    AmishLand, PA
    Posts
    894
    Hey Cody: How ya doing out there? Was just thinking of you the other day.

    Has to be one of the most common XB mistakes ever. Trying to install or jump-start from an ETX-14L when the correct battery is the 14. You're starting same place I would and remove and inspect every fuse...replace with identical amperage...and bet on the ignition and key-switch relays being fried. Scroll backwards thru this thread when I was user_deleted and I listed the factory relay part # and cross-overs. Same relay as Ford and Chrysler used on many A/C compressor relay circuits and available any auto parts store.

    If you find Cody that after completing all those checks and replacements...with key ON and kill switch ON....the fan randomly turns on and off as does the fuel pump....it's typically a fried ECM. Tell-tale sign.

    Josh is correct as usual about a potentially fried ECM and hopefully yours is not. I don't have any good used or NOS 2008 and later ECM's left but betting IDS does if you need one. One of the best looking and nicest riding XB's I ever owned was same thing....2009 XB12 "Long" Black edition. Great bike.
    Keep me posted and let me know if I can help.

  7. #17
    Senior Member BuellyBagger's Avatar
    Join Date
    Apr 2010
    Location
    Nebraska City, NE
    Posts
    3,692
    Hey John, doing good here. Thanks for thinking of me!

    So far I replaced the blown fuses and checked all. Replaced the key switch relay because there was only one available in town. Have more ordered. It will now prime the pump cycle gauges as usual and crank. Smells like it's getting fuel. I'm guessing the ignition relay is also shot so no spark. Going to start with that when the parts arrive and cross my fingers. It does sound like since I'm not getting the failed ecm symptoms you described I may have gotten lucky.

    This bike is actually originally a hero blue wheel and hero blue translucent bike. Unfortunately the kid rattle canned the plastics black. Hopefully I can bring em around. Also suffered a catastrophic rear wheel bearing failure. That is why it got parked. Don't know yet if the rear wheel is salvageable, but did order a new axle, spacer, and bearings.

    As always john, I appreciate your advice and wisdom. Thank you.20240504_140704.jpg
    Last edited by BuellyBagger; 05-05-2024 at 04:27 PM.

  8. #18
    Senior Member Barrett's Avatar
    Join Date
    Jun 2020
    Location
    AmishLand, PA
    Posts
    894
    Always my pleasure Cody and thanks much for the very kind words. I've only ever seen pics of a Hero Blue 2009 XB12Ss model...never one in person. Buell never kept records on translucent specific color production but 909 Ss models built for that year and only available in Hero Blue...Cherry Bomb...Midnight Black. Pretty damn rare model. They were some of the best Buells ever produced.

    If anyone can figure out how to strip the spray-bomb work off those two translucent pieces it will be you. Let me know if I can source any parts for you and post up your progress.

  9. #19
    Senior Member BuellyBagger's Avatar
    Join Date
    Apr 2010
    Location
    Nebraska City, NE
    Posts
    3,692
    Welp, picked up my other new relays. O'Reilly masterpro # r3146 same for borgwarner. Just replaced all four. After a little coaxing the bike fired and idled nicely for nearly a minute. It has been sitting outside for over a year so the battery is essentially junk, the fuel doesn't smell great, I wouldn't be surprised if the plugs have never been changed. Either way no cel and sounded good for that test run so I'm pretty confident the ECM survived.



Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •