Results 1 to 4 of 4

Thread: Speedo Problem

  1. #1
    Junior Member
    Join Date
    Sep 2018
    Posts
    14

    Speedo Problem

    Hello, I have a 2003 xb9s I bought used and it came with a large ugly RPM Gauge only. I ordered a Factory Buell speedo.
    When plugged my signals work and show on right side of tack and high beam lights working too.
    Nothing is working on the left side No back light mileage RPM or speed.

    When first plugged in the needles sweep but do not sweep when the key is turned on..... Any help would be great. I have been
    reading forums for days.....

    Thanks for any and all help
    cheers

    Mark

  2. #2
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,946
    You bought a factory new gauge cluster?

    If theres no Odo reading and the needles don't sweep when the key and run switch are turned on, I would check the ignition fuse and ignition relay.

  3. #3
    Junior Member
    Join Date
    Sep 2018
    Posts
    14
    No the cluster is used, I got another one from a member on Facebook Both Clusters do not sweep with key..... But they do sweep when I first plug them in.

    Ignition relay? Bike still starts and runs and the I tested the Wires going into the cluster I have constant power and an ignition wire that goes hot with the key.
    I'm going to try going through all the grounds tonight.

    Thanks again for all ideas on this one..........

    Mark

  4. #4
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,946
    If you have an ignition wire at the plug into the gauge assembly that gets 12v with the key switch and run switch 'on' there is an issue within the cluster. The only exception would be the ground connection at the same plug. Easy to check that.

    They are easy to separate to look for any visual clues of something burned or a pin bent, etc., or buy another one. Facebook strikes again...

    I have a couple ones that I know function. PM me if you want to try one, you can have it for the price of postage + $20



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •