Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: fuel pump noise ?

  1. #11
    Senior Member
    Join Date
    Mar 2015
    Posts
    1,280
    Quote Originally Posted by XB9-Vtwin View Post
    The previous owner claims no problems.
    Of course he doesn’t... “it runs, what’s the problem?”

    That is only bested by “Bike doesn’t run, easy fix”

  2. #12

  3. #13
    Senior Member lunaticfringe's Avatar
    Join Date
    Feb 2011
    Location
    AmishLand, PA.
    Posts
    7,517
    here's your situation and your remedies:
    1-i listened to your vid. your pump is shot. have heard these pumps emitting that racket 100X before and it signifies they're on their "death-bed". your future if not properly addressed? popped 10A pump fuse which you'll replace multiple times...then try a 15A fuse...then the pump will ultimately die at the gas pumps of some sh*t-mart 49 miles away from home and you're screwed.
    2-the pump in that link is garbage.
    3-click my name....click "find latest threads"...then start to scroll. i have listed ebay links to proper rebuild kits...factory OEM part numbers you'll need to order....housing O-ring info....vids of R&R for these pumps....how to rebuild articles. all there for your perusal and dissection.
    and please allow me to be blunt: you should spend less time clowning around on here with nonsensical "bring back buell" articles and focus your energies on repairing/replacing that pump. i can assure you it's going to leave you stranded.



Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •