Results 1 to 9 of 9

Thread: Fuel pump wonít prime after replacement.

  1. #1

    Fuel pump wonít prime after replacement.

    Due to ethanol in gas the old gas pump was deteriorated and fuel pump was replaced. When turning on the ignition the pump doesnít start. The meters sweep. If I test the pump it works when hooked up directly to the battery.

  2. #2
    Senior Member rchuff's Avatar
    Join Date
    Apr 2012
    Location
    Willow Grove, Pa
    Posts
    1,998
    Check fuel pump relay ,may be bad.

  3. #3
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    2,023
    That is under your seat and probably the first thing that should be checked after the fuse.

  4. #4
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,946
    Put a test light/voltmeter on the fuel pump wires to make sure both the battery and ground circuits are good. Rchuff is right, the FP relay and fuse should be checked, it's probably not the new pump.

  5. #5
    About the pump relay, canít find it. Under the seat there is a 30Amp (pink) fuse. And that big fuse canít be for the fuelpump

  6. #6
    Senior Member lunaticfringe's Avatar
    Join Date
    Feb 2011
    Location
    AmishLand, PA.
    Posts
    7,519
    aye aye aye....and it goes like this:
    1-your pump is supplied a constant 12 volts VIA the ignition relay AND the ignition fuse on earlier XB models. seeing as how you failed to even mention your year and model i won't bother posting up correct wiring schematic.
    2-your pump is fused via 10A fuse marked PUMP.
    3-the ignition relay....ignition fuse....pump fuse all well marked and in fuse-box under seat on lightning models.
    4-your pump receives its ground source via the ecm. with ignition switch AND kill switch set to run pump receives complete negative and positive circuits.
    5-check fuses mentioned above and replace the ignition relay. available at any H-D dealership PLUS i've posted up inexpensive cross-overs a million times on here. simply google me-buellxb.com to find them.

  7. #7
    Senior Member rchuff's Avatar
    Join Date
    Apr 2012
    Location
    Willow Grove, Pa
    Posts
    1,998
    Just a question, with key on do you have kill switch in the run position? Sometimes people forget to turn it on and if not in run position it will not prime. If yes follow all the above.

  8. #8
    Thanks a lot for all help. I cleaned all fuse terminals and put all fuses back and now it works

  9. #9
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,946
    Nice step by step Lunatic And seriously Rchuff is 2 for 2 with this one. Good catch man.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •