Results 1 to 2 of 2

Thread: Check Engine Light on, intermittent cutting out ~ 2003 Buell XB9R

  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    3

    Check Engine Light on, intermittent cutting out ~ 2003 Buell XB9R

    NEVER MIND! FIXED!!!! The guy who shipped it did a crappy job tying it down and he bent the sidestand. I bought a replacement stand and bolted it on but I fitted the sidestand cutout switch incorrectly and the bike thought the stand was down every time I let out the clutch and killed to motor! I called a buddy of mine with four Buells and the first thing he said when I mentioned the clutch lever was to check the sidestand switch!

    //////////

    You guys were helpful with my handlebar issue. I haven't raised the bars yet but wanted to ride the bike a bit before I do so today was to be my first ride.

    My' 03 XB9R starts right up, idles cleanly, no Check Engine light. Then I pulled away from my home but got halfway down the street and it cut off like I'd switched it off. Then it cut back in, then off, and the Check Engine light went on. I found it I pulled in the clutch, the light would go off and it would rev fine, but as soon as I let the clutch lever out, I could give it gas and in a couple of seconds it would cut out again. I nursed it back home. It idles fine, and revs in neutral fine, but it's unrideable. I'm not adept with "modern" bikes with computers and Check Engine lights!

    Is there an OBDII plug somewhere here like on a car to read codes? Would it be the same as for a modern car?

    Also, any independent Buell shops or experienced mechanics in the Los Angeles area?

    Any help would be much appreciated!

    ~ Dave
    Last edited by Dave~D; 01-19-2019 at 11:35 PM.

  2. #2
    Senior Member Silverrider's Avatar
    Join Date
    Sep 2016
    Posts
    2,586
    Quote Originally Posted by Dave~D View Post
    You guys were helpful with my handlebar issue. I haven't raised the bars yet but wanted to ride the bike a bit before I do so today was to be my first ride.

    My' 03 XB9R starts right up, idles cleanly, no Check Engine light. Then I pulled away from my home but got halfway down the street and it cut off like I'd switched it off. Then it cut back in, then off, and the Check Engine light went on. I found it I pulled in the clutch, the light would go off and it would rev fine, but as soon as I let the clutch lever out, I could give it gas and in a couple of seconds it would cut out again. I nursed it back home. It idles fine, and revs in neutral fine, but it's unrideable. I'm not adept with "modern" bikes with computers and Check Engine lights!

    Is there an OBDII plug somewhere here like on a car to read codes? Would it be the same as for a modern car?

    Also, any independent Buell shops or experienced mechanics in the Los Angeles area?

    Any help would be much appreciated!

    ~ Dave
    Is there an OBDII plug somewhere here like on a car to read codes? Would it be the same as for a modern car? https://www.buelltooth.com/
    Also, any independent Buell shops or experienced mechanics in the Los Angeles area? I have heard great reviews about Cooter he is a buzzy guy.

    Check ur clutch micro switch.


    Last edited by Silverrider; 01-19-2019 at 11:01 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •