Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Help! My 2007 XB12ss died on me

  1. #11
    Senior Member
    Join Date
    Mar 2015
    Location
    Phoenix, AZ
    Posts
    917
    Quote Originally Posted by Cooter View Post
    No offense to fenchie personally but any thread titled "HELP!..." is bound to be a cluster-f**k.

    Haha! This is an internet reality ^^^^^^^^^^^^^^^^^^^^^^^^^

  2. #12
    Junior Member
    Join Date
    Jan 2019
    Posts
    3
    Quote Originally Posted by Cooter View Post
    No offense to fenchie personally but any thread titled "HELP!..." is bound to be a cluster-f**k.

    None taken.
    If I ask you guys it's because I'm really new to all of this and would rather ask people with similar bikes with simpler words than the manual (in english, and it's not my first language) since I don't know much about all of this.
    thanks for the help tho!

  3. #13
    Senior Member
    Join Date
    Mar 2015
    Location
    Phoenix, AZ
    Posts
    917
    Quote Originally Posted by lunaticfringe View Post
    NO....not on his 2007. you really don't know much about these bikes do you ken?
    Attachment 11079

    Good call... is 2007 the first year of the "crank fire" ignition? I could never remember what year that happened, I just look at the cam cover.


    Last edited by 34nineteen; 01-30-2019 at 06:46 PM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •