Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Testing VR and stator health

  1. #1
    Senior Member Mesozoic's Avatar
    Join Date
    Jul 2008
    Location
    Tucson, AZ
    Posts
    207

    Testing VR and stator health

    Is there a definitive procedure to test the voltage regulator and the stator, separately? I made a 250 mile roundtrip journey on my '08 XB12Ss last weekend and the CEL came on the return trip. Pulled over at a gas station to fuel and feed, bike wouldn't start. Had to get jumped. Once running, I noticed that running the engine below 3000 RPM resulted in the CEL, for sure. If riding at 3000+ RPM sustained, the CEL would go away. Thinking that the battery may be weak, I replaced it with a new one - no luck, same issue. The engine used to charge ok above 3000 RPM, but now it's doesn't seem to be charging well, if at all, regardless of RPM.

    I'd like to test them out independently and definitively.
    Last edited by Mesozoic; 02-09-2019 at 02:12 AM. Reason: missing bike model

  2. #2
    Senior Member lunaticfringe's Avatar
    Join Date
    Feb 2011
    Location
    AmishLand, PA.
    Posts
    7,413
    Is there a definitive procedure to test the voltage regulator and the stator, separately?

    YES

  3. #3
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,356
    You are simply asking how to check your charging system and poor Lunatic has posted how to check the stator output (A/C voltage) and VR output so many times the keys on his computer are probably all worn out.

    To get your 'definitive' answer you can either search this commonly asked question on here or use the FREE .pdf manual download from Buellmods.com or Buelltooth.com to lead you step-by-step through the test without Lunatic going... well... all Lunatic
    Last edited by Cooter; 02-09-2019 at 04:18 AM.

  4. #4
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    1,758
    Can I have your good battery ? Just kidding but, does anyone use the search feature anymore ?
    There is also a way of checking the battery, before you buy a new one.

  5. #5
    Senior Member Mesozoic's Avatar
    Join Date
    Jul 2008
    Location
    Tucson, AZ
    Posts
    207
    I searched, but I didn't find the info I was looking for. I did however, find exactly what I was looking for in the '08 XB Electrical Diagnostics Manual on the BuellMods website.

  6. #6
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,356
    Finding your answers on Buellmods counts as searching, Mesozoic

    Glad you found what you needed. It's an easy test, hopefully you have a bad VR vs. a stator issue. The VR is easier to change and because its job is pretty universal you can find upgraded units easily and adapt one to your Buell.

  7. #7
    Senior Member Mesozoic's Avatar
    Join Date
    Jul 2008
    Location
    Tucson, AZ
    Posts
    207

    Confirm stator replacement needed

    I have some confusing results from testing my stator (following the instructions in the Buell electrical diagnostic manual).
    • The 1st check involves checking for continuity between ground and either of the stator leads. I have continuity between ground and both of my stator leads, which according to the manual "indicates a grounded stator which must be replaced."
    • The 2nd check is measuring resistance across both stator leads. My measurements fall within the 0.1-0.3 ohm spec, which is a bit unusual considering they're also continuous with ground.
    • 3rd check I performed was a direct stator AC output check. I'm seeing 30V at idle and 55V at 2000 RPM, which generally indicates solid functionality.

    I'm a bit confused as to why the stator would be generating any voltage if it was shorted, but almost all of my experience has been with DC circuits, so maybe I'm missing something here.

    The Buell manual states that if the AC output of the stator is good (which it is), the charging problem might be a faulty regulator. So I started going down that rabbit hole. I performed a milliampere draw test. I used 2 good meters to verify this and came up with a static 24.63 mA draw with the bike just sitting there with the key off, which is significantly over the max 2.0 mA spec. If I disconnect the regulator from the circuit, the draw drops down to 1.12 mA, which is much better. I would've thought that this meant that the VR's static draw is too high, but according to the manual's charging system troubleshooting tree, this indicates "replace grounded stator."

    So... would anyone like to confirm that this is indeed the case? Perhaps someone with a similar experience? I should mention that my issues began a few days after I installed the Buell heated grips kit. LOL

  8. #8
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    1,758
    It could be coincidence, but I would double check all the connections for the heated grips before proceeding.

  9. #9
    Senior Member Mesozoic's Avatar
    Join Date
    Jul 2008
    Location
    Tucson, AZ
    Posts
    207
    Actually, when I tested the bike I ran the current draw test while removing fuses from the fuse block. The heated grips do not cause a draw at all because the relay that energizes them is controlled by the ECM. The ECM senses when the engine is running and then energizes the auxiliary power relay which drives the heated grips. So... it's not the heated the grips. It's the large 30A fuse that has the 0.02563A draw on it, which appears to be labeled simply "Battery." Again, when I detach the regulator from the system, the draw disappears.

  10. #10
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,356
    Don't go replacing stuff just yet. You haven't even tested the VR output.



Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •