Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: High Performance 350 CCA Renegade Wicked Start Battery

  1. #11
    Quote Originally Posted by lunaticfringe View Post
    THE FACTORY INSTALLED OEM BATTERY in every Buell XB....XR1200....Sportster....V-rod....H-D big-twin built in the last 40 years is a DEKA house-branded for H-D/Buell.
    the Deka plant is right up the road from me. all USA content....employees....management....ownership. none of this Chinese garbage!
    As far as I know, this is exactly true !
    BTW, I bought a brand new DEKA ETX14 battery on 2017 December. It is said to be a 220cca battery. But it has been tested by the seller and it was actually going up to 379cca.
    Here is the picture of two tests of DEKA ETX14 and ETX14L (not mine) :

  2. #12
    Member antioch01's Avatar
    Join Date
    Jan 2013
    Location
    Dade City Fl
    Posts
    35
    Are you guys running the stock XB 1.0kw starters,, or the high torque 1.4kw starters ? I received the Renegade Wicked Start battery, and it is much better than the original battery, but there is still some compression bump.
    I read previous posts about upgrading to the 1.4kw high torque starter. But there were several complaints about oil leaks. I called Rare Electrical,, and they have improved their starters with an O-Ring at the front bearing to prevent the leak. They sent me a pic of the update. I will also post this on one of the other starter threads.
    Rare Electrical starter.png

  3. #13
    Senior Member Lusiphur's Avatar
    Join Date
    May 2015
    Posts
    367
    Nope. Stock 2006 starter on mine.
    Jack-O-Lantern
    2006 Buell XBRS LightningBolt
    http://www.buellxb.com/forum/album.php?albumid=129

  4. #14
    Senior Member Silverrider's Avatar
    Join Date
    Sep 2016
    Posts
    2,444
    Mine cranks over well with 240 CCA ,Once they get there streaming up. Robert , If it ant broke don't fix it.

    IMG_3683 by Jack Joseph, on Flickr
    Last edited by Silverrider; 03-05-2019 at 03:53 PM.

  5. #15
    Member antioch01's Avatar
    Join Date
    Jan 2013
    Location
    Dade City Fl
    Posts
    35
    Quote Originally Posted by lunaticfringe View Post
    if you're that annoyed about a non-curable "nature of the beast" situation then just prior to starting simply click the bike into 2nd gear...paddle back a few inches....then put into neutral...pull in the clutch...and fire it. that little delicate move gets the offending piston off TDC compression stroke. then again that's a geezer trick for big-twins when electric start first appeared on the H-D scene and it was horrible. might be too simplistic for you?
    No,, actually I am a pretty simplistic guy,, still have a kick shovel. But if I go back on Chemo I may not have the strength for that. I have tried the other trick of bumping the starter and then hitting it again before it comes back up on the compression. Both seem to work, but from what I have read the 1.4kw starters work well, so I thought I would try one.

  6. #16
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,359
    That was the exact (super frustrating) problem I had with a Rare Electrical starter on an XB, and the source of many many e-mails and pictures to them once I found the issue. It would pour primary oil through the starter body at high RPM.
    I am super surprised they are solving the problem, that's 'Rare' (PUUUNNN) for a Chinese company. But I was unhappy they kept selling them even after they knew what was wrong.

    The "1.4kW" body is still on the bike with a Buell OE nosecone (and sealed bearing) but I still got compression bump with it so I'm not so sure about the accuracy of the specs. I put in the Li-Ion battery from an EBR and bam, she can sit for months and still spin over with ease. Looks like I found my solution

  7. #17
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    1,760
    I'm curious, Antioch, are you the original owner, I'm asking because you said it's the original battery or did you mean it's the original brand ? I have had the compression lock up on the turn over on start up, they both kick right over on the second try, so I know nothing's broke.



Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •