Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: XB9S Gas Tank (Frame) cleaning Help

  1. #11
    Junior Member
    Join Date
    Oct 2018
    Posts
    9
    Hello Lunatic fringe. That link to the Ford barn was spot on. I believe it is the same black flaky substance. Now the issue is cleaning without volatile chemicals. Thanks for offer on the pump, already purchased a new one and all the rest to rebuild the pump assembly. Next idea is to make a special spray nozzle for the pressure washer to go down the right side of the tank.

  2. #12
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    1,859
    Steam it out !

  3. #13
    20190421_193158.jpg

    Hello all, first post here. Picked up a more or less free basket case over the weekend, an 09 Firebolt basket case that has been sitting for several years. It fires when primed but its not getting fuel so I yank the pump and find this. So it need another pump assembly in addition to battery and all new fluids, who knows what else. I think I'm going to yank the injectors and throw them in some Seafoam, hope for the best. I may hack off the pump plate and seal up the tank where I can fill it with seafom, wrap the pump assembly in a fuel sock and cross my fingers.

  4. #14
    Senior Member
    Join Date
    Mar 2015
    Location
    Phoenix, AZ
    Posts
    1,139
    I wonder if that is POR-15 tank sealant? Sure looks like it by the color. But why in a aluminum tank?

    See lunaticfringes post on here where he is selling new fuel pump assemblies.

  5. #15
    Junior Member
    Join Date
    Oct 2018
    Posts
    9
    Hello Noel,

    Do not hack that pump. One E clip holds everything together. Take it apart and then use it as cap and clean out the tank while you wait for replacement parts to rebuild it. There is a wealth of info here to get the parts you will need. I used one O-ring with some grease on it. I makes it easy to push on and pull off easy to drain your tank. I didn't pull the injectors on mine. After rebuilding the pump assembly, it started right up and after a TPS reset and installing the muffler, it just purred. I'll run some Seafoam thru it. Note final assembly, I used both O-rings when I installed pump.
    Last edited by 45vtwin; 04-23-2019 at 01:41 AM.

  6. #16
    Quote Originally Posted by 34nineteen View Post
    I wonder if that is POR-15 tank sealant? Sure looks like it by the color. But why in a aluminum tank?

    See lunaticfringes post on here where he is selling new fuel pump assemblies.
    I think you are correct, when it seeped out it had almost an rtv consistency, but after a day of sitting in the air it set up almost like an epoxy tank coating? Either way the old assembly was terribly caked, the lines just snapped and broke into pieces. As best I can tell this thing has 8K miles and has been sitting unridden with fuel in it since 2010ish so who knows. I think I'll start a new thread about the bike because it makes me laugh now and then. For instance, the previous owner spent much more time installing LED lights and Harley stickers than they did repacking the exhuast... in fact I'm suspecting they cut the aftermarket can open to remove packing in an attempt to make it louder. There were 2 tiny little bits of packing in the can.


    Thanks everyone for the help, I'm sure I'll have hundreds more questions.



Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •