Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: MAP/Baro sensor on XB Mod help

  1. #31
    Senior Member rb70383's Avatar
    Join Date
    Jul 2008
    Posts
    348
    attachment of the muffler no worky.

  2. #32
    Junior Member
    Join Date
    Jan 2019
    Posts
    22
    Just got back from AZ for Thanksgiving.....was in CA from 1986 to 1993 and came back in 2013....hard to beat the weather for motorcycle riding...once I get done with a couple car projects will get back to the old Buell...

  3. #33
    Junior Member
    Join Date
    Jan 2019
    Posts
    22
    been here since 2012, was living here before from 1986-1993...great to be back as it has some of the best riding weather, scenery to offer in the country...

  4. #34
    Senior Member
    Join Date
    Jan 2016
    Posts
    561
    Weather is great, too bad the state itself sucks.

  5. #35
    Senior Member rb70383's Avatar
    Join Date
    Jul 2008
    Posts
    348
    I'm still waiting for it to slide off the country and finally get water front property in AZ.
    Hopefully I get to make the trip down the coast one day before that happens.

  6. #36
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    6,972
    Quote Originally Posted by Outlaw View Post
    Weather is great, too bad the state itself sucks.
    The state is just fine Thank You.




    Its the people I can't stand

  7. #37
    Senior Member
    Join Date
    Jan 2016
    Posts
    561
    Yer probably right



Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •