Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Headlamp Bulbs Blowing

  1. #1
    Junior Member
    Join Date
    Sep 2016
    Location
    Kent
    Posts
    9

    Headlamp Bulbs Blowing

    I have an 08 XB12S and within the last week, had 3 headlamp bulbs blown.
    Having read similar problems on here, I checked battery voltage, 12.6v. Started engine and voltage went to 14.4v, revving showed no increase in voltage.

    Am I correct in assuming this means the stator is working , as we have an increase in voltage on running, but the regulator is dead as no increase on throttle?

  2. #2
    Senior Member Silverrider's Avatar
    Join Date
    Sep 2016
    Posts
    2,722
    Most likely your VR is on the the way out, bulbs are cheap replace it before it fries relays and ECM. JMO

  3. #3
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,048
    A VR going bad can cause intermittent voltage spikes and the symptoms you are having.

  4. #4
    Senior Member
    Join Date
    May 2016
    Location
    Central Soviet state of new jersey.
    Posts
    2,332
    I don't think it should show that high of a voltage unless you rev it up so yes it's probably the VR, that's what I'd be replacing.

  5. #5
    Junior Member
    Join Date
    Sep 2016
    Location
    Kent
    Posts
    9
    Cheers, confirmed my suspicions.

    Only trouble is now, where to find one in stock! Might be better trying for Rocking Horse Poo!

  6. #6
    Junior Member
    Join Date
    Sep 2016
    Location
    Kent
    Posts
    9
    Quote Originally Posted by lunaticfringe View Post
    Sir: the OEM part # for the VR is Y0302.5A8---suffix L19D. it is single phase and both legs of harness attach behind the factory left side air scoop. i keep good used and new ones in stock. check a dealer in your country for availability. you can also retro-fit harley-davidson part # 74711-08 which is cheap and plentiful both new and used but several labor-intensive mods need to be done to make it fit the stock mounting points.
    Many thanks for the info, I had seen a post about the HD part, I assume that is the one that needs the wires extended and new mounting plate? I will look into that if I can’t find an OEM part for my bike.

    Having searched internet extensively last couple of days, they do seem to be either not available or second hand in UK. I am waiting on a call back from Harley to see if they have one in they’re system.

    I have had poor experience with buying second hand parts, last one I bought for my Buell I paid 60% of new price for a part that failed within 2 months and the seller was not interested. When I looked inside, it had been ‘fixed’ with 2 part epoxy! As the VR is a solid state unit, I have no way of confirming it works until I fit it.

  7. #7
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    8,048
    Since you're in the UK... have you tried Twin Motorcycles in the Netherlands?

  8. #8
    Junior Member
    Join Date
    Sep 2016
    Location
    Kent
    Posts
    9
    Quote Originally Posted by Cooter View Post
    Since you're in the UK... have you tried Twin Motorcycles in the Netherlands?
    Hi, thanks, I had tried them, but website wasn’t working, just retried and ordered one. Just got to wait for it to arrive now!

    Damn, just checked order confirmation and it’s on back order so no idea how long that will take and I use my bike for work, back to searching!
    Last edited by Cutri; 12-15-2019 at 04:50 PM.

  9. #9

  10. #10
    Junior Member
    Join Date
    Sep 2016
    Location
    Kent
    Posts
    9
    Hi, this is wrong item for my bike, thanks for helping though.



Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •