Results 1 to 3 of 3

Thread: Removing the Oil Pump Drive Gear - 2003 Blast

  1. #1
    Junior Member
    Join Date
    May 2020
    Posts
    3

    Removing the Oil Pump Drive Gear - 2003 Blast

    I have been unsuccessful in finding someone locally with the HD-43984 Crankshaft Locking tool remove the nut on the crankshaft so I can replace a damaged oil pump drive gear on my 2003 Blast.

    If anyone can let me know what to do an an option or has one they aren't using that I can borrow or buy cheap?

    Any help would be appreciated.

    I should say, I am also looking for the Oil Pump Drive gear and a new oil pump. It was recommended to me to use the new brass one but the cheapest I have found is $98. Pumps vary in price. Bought the bike used and the person selling didn't say it had any problems. Of course after I got it home and found out there was no oil in it, I realized they knew and were not honest about the whole thing.
    Last edited by tomcat7; 05-24-2020 at 05:18 PM.

  2. #2
    Member
    Join Date
    May 2018
    Location
    Vancouver WA
    Posts
    31
    I forget the exact length but a piece of 1/4 thick 1 1/2 by about 6 1/2 long steel from Home Depot they sell 2ft pieces and you can cut it to length is all I have used in the past. It would cost more to send it to you than you can make your own for. Make sure you use the updated torque spec if youíre using Blast service manual and locktite. I lost the splines on a crank at 1600 original miles. Used the book specs and when I took it to a Buell dealer they said those bikes vibrate itís normal.

  3. #3
    Junior Member
    Join Date
    May 2020
    Posts
    3
    Quote Originally Posted by cvc View Post
    I forget the exact length but a piece of 1/4 thick 1 1/2 by about 6 1/2 long steel from Home Depot they sell 2ft pieces and you can cut it to length is all I have used in the past. It would cost more to send it to you than you can make your own for. Make sure you use the updated torque spec if youíre using Blast service manual and locktite. I lost the splines on a crank at 1600 original miles. Used the book specs and when I took it to a Buell dealer they said those bikes vibrate itís normal.
    I have a service manual but not the new Torque specs. Any assistance would be great.

    Also, I believe my gears were off what I have been seeing here for Timing. I should just line the timing marks up with what folks say here?

    Thanks!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •