Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: Differences between 2003 & 2005 XB9

  1. #21
    Quote Originally Posted by 34nineteen View Post
    I’ll have to check my big book of wiring diagrams and trouble codes.
    Thanks a million!

  2. #22
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Location
    lunatic_fringe is ___________ my spirit animal
    Posts
    3,330
    Maybe itís a bad tps. It is a mechanical sensor and the bike is only 15+ years old. It wouldnít hurt to investigate. Iíve heard stories of the throttle shafts breaking so itís worth a look.

  3. #23
    Quote Originally Posted by 34nineteen View Post
    Maybe itís a bad tps. It is a mechanical sensor and the bike is only 15+ years old. It wouldnít hurt to investigate. Iíve heard stories of the throttle shafts breaking so itís worth a look.
    Installed a brand new TPS, no change. The fuel mixture is definitely effected past 40% since the engine wants to die instead of leveling off, right? Would the oxygen sensor effect the fuel mixture based on the throttle position?

  4. #24
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Location
    lunatic_fringe is ___________ my spirit animal
    Posts
    3,330
    Have you checked fuel pressure? It’s not uncommon for the fuel pumps to start flaking out at this point. The gauge is relatively cheap from Buelltooth.

    Or maybe your injectors are plugged and only able to flow enough for low power applications.

    You could switch to open loop and bypass the o2 sensor. Upaero would be happy to talk about that.. or you can read about it on the Buelltooth webpage

  5. #25
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    9,173
    AFV isn't affected that fast. If the issue is in the tuning, your description sounds when the bike goes from Closed Loop (reading to O2) to Open Loop (reading the map).

    What is the EGO corr(ection) value? Should be about 100.

  6. #26
    Quote Originally Posted by 34nineteen View Post
    Have you checked fuel pressure? It’s not uncommon for the fuel pumps to start flaking out at this point. The gauge is relatively cheap from Buelltooth.

    Or maybe your injectors are plugged and only able to flow enough for low power applications.

    You could switch to open loop and bypass the o2 sensor. Upaero would be happy to talk about that.. or you can read about it on the Buelltooth webpage

    It has good torque and runs smooth up to that 40% throttle area and will run 70 mph without missing a lick. It’s only when I twist past 40% that it wants to die.

  7. #27
    Quote Originally Posted by Cooter View Post
    AFV isn't affected that fast. If the issue is in the tuning, your description sounds when the bike goes from Closed Loop (reading to O2) to Open Loop (reading the map).

    What is the EGO corr(ection) value? Should be about 100.

    Can I check this with the buelltooth? Which section? I can check when I get home tonight.

  8. #28
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Location
    lunatic_fringe is ___________ my spirit animal
    Posts
    3,330
    It’s under data channels. You can have 4 running on the screen at once. You may need to change one to it to view that data.

  9. #29
    Quote Originally Posted by Cooter View Post
    AFV isn't affected that fast. If the issue is in the tuning, your description sounds when the bike goes from Closed Loop (reading to O2) to Open Loop (reading the map).

    What is the EGO corr(ection) value? Should be about 100.
    EGO Correction is 145%

    I’m researching what that means...
    Last edited by DSophia; 03-01-2021 at 04:11 AM.

  10. #30
    How is the EGO Correction adjusted?



Page 3 of 5 FirstFirst 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •