Results 1 to 6 of 6

Thread: 2008 XB12SS Bogging down, running poorly

Hybrid View

  1. #1
    Junior Member
    Join Date
    Aug 2019
    Posts
    4

    2008 XB12SS Bogging down, running poorly

    Hi all, my 2008 XB12SS went from running fine to bogging down when opening the throttle with sudden lurches in acceleration. Idling is fine. I had replaced the intake seals a month or so before and checked them with the spray test and they worked fine. Also did ground point cleaning at the same time.

    Tried a TPS reset which made no difference.
    Hooked up a cable and looked at error codes. Had AMC stuck closed error. The valve did look gummed up on the muffler, gave it a good clean, oiled the cables and checked the dc motor and its all working fine now but it made no difference.
    Pulled the plugs and they did look fouled so replaced them and the their cables but no change.
    Checked AFV value and it was sitting at 140 which seems very high.
    Got myself a fuel pressure tester and checked the pump when primed and when running, value is sitting at 49 - 51 PSI which I believe is normal.

    So now I'm a little flummoxed. I did find some grey sealant (or something) around the PCV valves and grommets which makes me wonder if the PO had a similar problem and tried sealing these up. There was a small amount of oil residue around the rear one and both the front and rear grommets do seem quite loose. If these were shot could they be the problem?.

    Any other suggestions would be welcome. Really want to get her back on the road again!

  2. #2
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    9,395
    Step back a bit and start again with the basics. Everything you are saying leads to a lack of fuel and the ECM is trying to compensate.
    Either too much air or not enough gas. Check the things that cause that.

    You say you have no intake leak and 50psi of fuel pressure while having the problem, so that narrows it down to a flow problem or injector problem. Have them sonic cleaned? FYI the front and rear are different

  3. #3
    Senior Member Barrett's Avatar
    Join Date
    Jun 2020
    Location
    AmishLand, PA
    Posts
    323
    There was a small amount of oil residue around the rear one and both the front and rear grommets do seem quite loose. If these were shot could they be the problem?.



    NO

    Sir: it is NOT an AMC. does not exist. your referencing the ACM. buell acronym for Actuator Control Module.
    just dealt with precisely your identical problems on 2 shop bikes in past month. problems being: complete lack of any decent throttle response....falls flat as if total fuel delivery loss when hard throttle applied....climbing AFV on 1 bike....not on another.

    you failed to specifically mention it, but you'll have both historical and active fault code #21.
    your ECM is seeing values for your IEV system it doesn't like. opening voltage problem....closing voltage problem...ground short. that's it.

    what resolved these identical issues on the COMBINATION of the 2 bikes i just referenced?
    1-crack at rear exhaust header O2 sensor bung
    2-kinked IEV actuator cable
    3-IEV with interference movement close to being locked shut
    4-expired O2 sensor without #13 failure
    5-faulty IEV actuator with multiple internal failures
    6-loose battery cables at both terminals
    7-ECM ground wire issue

    check all on your XB.
    good luck.

  4. #4
    Junior Member
    Join Date
    Aug 2019
    Posts
    4
    Thanks Cooter and Barrett, I got the injectors cleaned but that didn't fix it. Looked at the 02 sensor next and after a bit of a struggle getting it out and replacing it + a TPS reset, she has been behaving. The help was much appreciated.

  5. #5
    Senior Member Barrett's Avatar
    Join Date
    Jun 2020
    Location
    AmishLand, PA
    Posts
    323
    Yes Sir my pleasure. Glad you're up and running.

  6. #6
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    9,395

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •