Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: High AFV and lean popping on Decel

  1. #11
    Senior Member d_adams's Avatar
    Join Date
    Apr 2010
    Location
    Just outside of St. Louis
    Posts
    3,527
    Quote Originally Posted by 34nineteen View Post
    OK, dont replace the sensor then. Do whatever you want.

    PS. Having the service manual and actually reading it are two separate things.

    Here is your award. Sorry the problem wasnt easier to solve.


    Gonna leave that post as is. I read through the whole thread and found your most likely problem.

    Tune came from Revision Moto.

    That right there is 99% of your issue. Want to actually fix it? Get an ecm from IDS (www.idspd.com) that matches the exhaust you have on the bike. IF it actually *is* a Buell factory P&A race exhaust, then this is the part you need to order. https://idspd.com/xcart/buell-xb12-04-07-pa-ecm.html

    Install that, do a TPS reset (I highly recommend the CMI-Lite tool, which is also available from IDS) *CORRECTLY* and most likely your problems will be done and over with.
    If it still doesn't run correctly after that, then odds are the O2 sensor could be a problem. It does happen on occasion, but not often. As pointed out above, it is NOT a difficult process to replace it.

  2. #12
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Location
    Buc-ees
    Posts
    3,644
    Quote Originally Posted by tacopwr View Post
    I hope you make it out of your momís basement one day. Get a fukking life.

    Wow, what is with all the anger?

    If you dont want to replace the O2 sensor, dont do it. I dont care. You're the one who came on here asking for advice on how to fix your motorcycle. I gave you advice, you said it was too much of a pain in the ass.

  3. #13
    Senior Member d_adams's Avatar
    Join Date
    Apr 2010
    Location
    Just outside of St. Louis
    Posts
    3,527
    Quote Originally Posted by tacopwr View Post
    I hope you make it out of your momís basement one day. Get a fukking life.
    And after someone tries to help you, this is the fast way to find a new hobby somewhere else. You won't get much more help if you can't do better than that.

  4. #14
    Junior Member
    Join Date
    Jun 2021
    Posts
    9
    Quote Originally Posted by d_adams View Post

    That right there is 99% of your issue. Want to actually fix it? Get an ecm from IDS (www.idspd.com) that matches the exhaust you have on the bike. IF it actually *is* a Buell factory P&A race exhaust, then this is the part you need to order. https://idspd.com/xcart/buell-xb12-04-07-pa-ecm.html

    Install that, do a TPS reset (I highly recommend the CMI-Lite tool, which is also available from IDS) *CORRECTLY* and most likely your problems will be done and over with.
    If it still doesn't run correctly after that, then odds are the O2 sensor could be a problem. It does happen on occasion, but not often. As pointed out above, it is NOT a difficult process to replace it.


    So it isn't possible to run the stock ECM (and modified tune) with the Buell race exhaust? I’m pretty certain it is the actual Buell part by looking at the tips. Is there another method of identifying? The ECM ID is BUIEB
    Last edited by tacopwr; 10-21-2021 at 08:48 PM.

  5. #15
    Senior Member d_adams's Avatar
    Join Date
    Apr 2010
    Location
    Just outside of St. Louis
    Posts
    3,527
    It *is* a Buell factory race part (P&A stands for Parts and Accessories) and you can run a stock calibration for a very short time, but it will run lean like yours has. It (the ecm) will try adjusting to correct itself, but there is a limit on how much it can do so before finally running like crap.

    I am assuming your exhaust looks like this one. https://www.buellxb.com/forum/showth...XHAUST-Muffler

  6. #16
    Junior Member
    Join Date
    Jun 2021
    Posts
    9
    Yes that is the exhaust that is installed.

    Revision Moto sent me the tune base on the ECM and that Exhaust info I provided. Are they known to be untrustworthy?

    I will gladly run through everything again this weekend, check intake seals, and replace the O2 sensor. No idea why that guy kept repeating that I would refuse to replace it.
    I will get a log as well and hopefully that will tell me if anything is still messing up.

    I can try the unknown tune that came on the bike since I saved it, but I flashed with the Revision Moto tune with the assumption that was known to be the correct tune for the exhaust. I assumed the previous owner never updated the tune after installing the exhaust.

  7. #17
    Senior Member d_adams's Avatar
    Join Date
    Apr 2010
    Location
    Just outside of St. Louis
    Posts
    3,527
    Shady dave does some questionable ****.

    Seriously, if you want it done right, contact Tim at IDS. They are the OEM manufacturer of the ecm, both stock and race units. Physically, they are the same thing but the race unit does not have the EPA restrictions. Get it from a KNOWN and GOOD source. If you can afford the down time by sending in your original ecm, have them do a re-flash on it at IDS.

  8. #18
    Junior Member
    Join Date
    Jun 2021
    Posts
    9
    Quote Originally Posted by d_adams View Post
    Shady dave does some questionable ****.

    Seriously, if you want it done right, contact Tim at IDS. They are the OEM manufacturer of the ecm, both stock and race units. Physically, they are the same thing but the race unit does not have the EPA restrictions. Get it from a KNOWN and GOOD source. If you can afford the down time by sending in your original ecm, have them do a re-flash on it at IDS.
    Well that is a bummer. I did get the replacement fuel pump and injectors cleaned by RM as well.
    I will check out IDS if this doesn't work out. Thank you for the recommendation.

  9. #19
    Senior Member
    Join Date
    Apr 2019
    Location
    Phoenix, AZ
    Posts
    260
    Quote Originally Posted by d_adams View Post
    Shady dave does some questionable ****.

    Seriously, if you want it done right, contact Tim at IDS. They are the OEM manufacturer of the ecm, both stock and race units. Physically, they are the same thing but the race unit does not have the EPA restrictions. Get it from a KNOWN and GOOD source. If you can afford the down time by sending in your original ecm, have them do a re-flash on it at IDS.
    Hey Dean, just out of curiosity, what do you believe is the matter with rev-mo tunes? They claim to be the factory tunes for each specific pipe, but I of course have no way to verify that. I bought my dongle through him, and used his Jardine tune which seemed to run better, but I'm in no way an expert.

  10. #20
    Senior Member GregoXB's Avatar
    Join Date
    Feb 2012
    Posts
    1,542
    Quote Originally Posted by tacopwr View Post
    I hope you make it out of your momís basement one day. Get a fukking life.
    TeaBag? Can it be?



Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •