Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Buelltooth needed in Aus

  1. #1

    Buelltooth needed in Aus

    Hey there Buellers just trying to get a hold of a bluetooth dongle to diagnose a very unhappy 05 xb12ss lightning. 59000kms EBR race chip with factory race muffler k&n filter. Has run beautifully up to this point.
    Only dongles I can find are on the Rev Moto site that don't ship to Aus.
    Bike won't idle without feathering throttle and will then surge and backfire.Was running (Unrideable in present condition) Have checked TPS voltage and all in spec replaced fuel pump, and regulator and inline filter, filter bag,
    new plugs,leads,checked coil (All Good) New injectors (both were pretty dirty and front basket was slightly misformed) new intake seals while as i was that far in (old ones not leaking but 15yrs old) Pulled O2 sensor and bench tested (still operating) tested air intake temp sensor (all good) overheat temp sensor wire checked (no breaks or cuts) Cleaned and retightened all the grounds i could find, has a healthy battery. Has fault codes I got from jumping pins in ecm port 11,15,23,33 Not sure if historical or not. After all this its still doing the same thing.
    Any help locating a bluetooth dongle so i can clear these codes and get a live reading would be great. Any other thoughts appreciated as well
    Cheers Rod

  2. #2

  3. #3
    Senior Member Barrett's Avatar
    Join Date
    Jun 2020
    Location
    AmishLand, PA
    Posts
    484
    Rod: Shipping to Australia or Austria? If OZ, as of right now your Royal Postal Service only accepting USPS Priority Air EXPRESS....NOTHING else.Flat rate packet cost to OZ is $46. Rev outfit, through no fault of their own, probably not aware of that. Hence, shipping refusal. Make the purchase...have it shipped to me...and I'll fire it over to you as a favor.

    All your listed fault codes are typically loss-of-ground related. The ECM is seeing values it doesn't like resulting in the actives/historicals. Recheck ALL again, particularly the ECM grounds and possible compromised ECM harness plugs.

  4. #4
    Member DieterVonCunth's Avatar
    Join Date
    Jul 2020
    Location
    Tromsų, Norway 70° north
    Posts
    90
    Quote Originally Posted by Rodasinfishing View Post
    Hey there Buellers just trying to get a hold of a bluetooth dongle to diagnose a very unhappy 05 xb12ss lightning. 59000kms EBR race chip with factory race muffler k&n filter. Has run beautifully up to this point.
    Only dongles I can find are on the Rev Moto site that don't ship to Aus.
    Bike won't idle without feathering throttle and will then surge and backfire.Was running (Unrideable in present condition) Have checked TPS voltage and all in spec replaced fuel pump, and regulator and inline filter, filter bag,
    new plugs,leads,checked coil (All Good) New injectors (both were pretty dirty and front basket was slightly misformed) new intake seals while as i was that far in (old ones not leaking but 15yrs old) Pulled O2 sensor and bench tested (still operating) tested air intake temp sensor (all good) overheat temp sensor wire checked (no breaks or cuts) Cleaned and retightened all the grounds i could find, has a healthy battery. Has fault codes I got from jumping pins in ecm port 11,15,23,33 Not sure if historical or not. After all this its still doing the same thing.
    Any help locating a bluetooth dongle so i can clear these codes and get a live reading would be great. Any other thoughts appreciated as well
    Cheers Rod
    How can anyone read this?

  5. #5
    Senior Member
    Join Date
    Jan 2016
    Posts
    773
    Reads fine to me.

  6. #6
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    9,950
    I can read it. Lots of dense info to digest but totally understandable considering his lengthy diagnosis and repair so far.

    Super nice offer Barrett, thats very generous! Perhaps Rod could reach out personally to Buelltooth via e-mail and see if they make an exception? It seems like the right path to continue diagnosing and keeping a Buell alive.

    Thanks for the info OP. The way you describe the popping while feathering the throttle, it could still be a fueling issue or timing. Is it popping through the intake? Exhaust? Both? Got a video to post? A quick test would be to spray carb cleaner in the TB while trying to run it. If it is still a lack of fuel (or too much air) issue, it should perk right up while spraying it.

    ECMDroid (using the Buelltooth) is a fantastic diagnostic device, but won't tell you fuel pressure on an XB.
    It would be worth it to tee in a pressure gauge and try to run the bike, because a static pressure test can miss a weak pump, and non-OEM Buell "compatible" fuel pumps are questionable at best and can be supplied with the wrong regulator (Thanks Mike Lowerey). You're looking for 49psi. Should be rock solid at any load. These work great to add a line and gauge without chopping the stock fuel lines up:
    https://www.amazon.com/Dorman-800-17...a-570582703664

    Also you mentioned they were quite dirty, I'll assume you flushed the fuel rail before installing the new injectors?

    If all thats ok and you're still waiting for the Buelltooth dongle, It might also be worth throwing a CPS sensor at it. The cam position sensor doesn't always just fail and stop working. It could cause the timing to be all over the place and pop and bang while trying to run. Part # 324430-04 and still available but not cheap I wouldn't be surprised if theres a less expensive HD Sportster compatibility for such a simple sensor. Perhaps our esteemed Barrett would know?
    Last edited by Cooter; 12-04-2021 at 05:16 PM.

  7. #7
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Location
    Buc-ees
    Posts
    3,895
    If the Buelltooth guy won’t ship you one, just buy one from twin or build one, or buy the cable instead.

  8. #8
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    9,950
    To Aarons point, it is literally a .50¢ Deutch connector, $1 Bluetooth module, and .50¢ 5Vdc convertor. ECMDroid only works Bluetooth (no cable), or you'd have to learn ECMSpy or TunerPro. I have a cable to send you if you choose to go that way, but just like the dongle, the cable is a .50¢ USB end (that frankly you could cut off anything in your junk drawer) and the same .50¢ Deutch connector.

  9. #9
    Thanks for the link Dieter

    Cheers

    Rod

  10. #10
    Barrett: I am from OZ and Thanks very much for all the info and your generous offer. Really appreciate it. I'll try my best to check all the grounds again today with my limited electrical skill set. There's no visible damage to ecm plugs,visible wires or housing but will try and test.

    I'll leave my email below to swap details to take you up on that offer.

    Cheers Rod

    Email: oscaroscar.thompson@gmail.com



Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •