Results 1 to 7 of 7

Thread: Stator failure on AM commute

  1. #1
    Senior Member Mesozoic's Avatar
    Join Date
    Jul 2008
    Location
    Tucson, AZ
    Posts
    383

    Stator failure on AM commute

    It finally happened - a balmy 50*F morning ride and the battery indicator lights up and the voltage shows about 12.0V and dropping. Fortunately, was able to turn around and return to my garage to grab a different bike.

    So what's the best recourse? I've heard obtain a Rick's stator and perhaps perform/obtain the oil cooling mod. I figured I might also entertain replacing the regulator for an upgrade while I'm at it. I could smell the stator when I parked the bike, not sure what else would've fried. Probably needs an oil change now.

  2. #2
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Location
    Kolache Factory
    Posts
    4,419
    I’d first verify whether the stator (and) or the regulator failed.

    I don’t know how you would have smelled a failed stator since it’s inside the case. Regulator… sure

    If you can get the EDM drilling done on the rotor, I’d recommend that first as (IMO) that is the root cause for charging issues on the 09-up 1125’s. Everything else is a band aid.

    Maybe Buell can do it, since the 1125 and 1190 are “basically the same platform”.

  3. #3
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    10,833
    What year is the bike? -08?-09? I have all sorts of 1125 parts, including a new stator., Harley "fix" harness. Not sure if the rotor is drilled. PM me if you need something.

  4. #4
    Senior Member Mesozoic's Avatar
    Join Date
    Jul 2008
    Location
    Tucson, AZ
    Posts
    383
    The bike is a 2009 1125CR. I've not torn into it yet, but I will eventually. The bike has been running the Harley "fix" harness since I've owned it, I figured I'd deal with it one day, but have not had an excuse to until now.

  5. #5
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    10,833
    Once you test to verify (EZ and in the manual), post up.
    The VR is a standard piece and even has "Ducati" molded in the body. Thats a more common failure than a stator, even on these.

    I used to hate the Harley 'fix' thinking it was a band-aid, and dismissing it's brilliance. If it was an OE feature, we'd be impressed When the charging system doesn't need to supply full amperage, it simply turns off one stator leg to keep the amp dump to a minimum and that keeps it cool.

    A better solution would have been a MOSFET, non-shunt style of VR (and you can dive down that wormhole if you want) but either way, fix the issue, upgrade if you want... but Id leave the 'fix'.

  6. #6
    Senior Member 34nineteen's Avatar
    Join Date
    Mar 2015
    Location
    Kolache Factory
    Posts
    4,419
    Quote Originally Posted by Cooter View Post
    I used to hate the Harley 'fix' thinking it was a band-aid, and dismissing its brilliance. If it was an OE feature, we'd be impressed When the charging system doesn't need to supply full amperage, it simply turns off one stator leg to keep the amp dump to a minimum and that keeps it cool.
    Ok, McConaughey… I’ll give you that one

  7. #7
    Senior Member Cooter's Avatar
    Join Date
    Dec 2012
    Location
    Crawling up your skirt
    Posts
    10,833
    Screen Shot 2023-12-20 at 7.43.48 PM.png

    Alright alright alright



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •