Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: XB12ss Electrical Woes

  1. #11
    Senior Member
    Join Date
    Mar 2010
    Posts
    115
    Tagging in on this thread. 09 Firebolt. Won't crank, don't even hear a relay click when I try.

    It's been in a front end collision so it has some damage. Key turns on, gauges work as normal, but no neutral light. I've grounded the neutral switch wiring at the pulley but I don't get a dash neutral light when I do. I've swapped the gauge bulbs around and it's not a bulb issue. Check engine light will come on shortly after the gauges cycle.

    Switchgear doesn't seem to be an issue. Fuel pump cycles when I cycle the kill switch and more importantly I've swapped with a known good switch.

    Initially I was getting the following codes:

    36 - Cooling fan 1 (rear or right) short to ground
    44 - BAS too high (bank angle sensor, which is missing)
    21 - AMC stuck open. (exhaust valve, which has been disconnected / removed)

    Using ECMDroid I disabled the bank angle sensor related functions and the 44 code went away. Disabled the exhaust valve functions and the 21 code went away. Just have the 36 code now, but it still won't crank, still no neutral light, and the CEL is still on.

    Clutch switch and wiring seems intact visually but I haven't tested it with a meter yet. I'll do that next week when I'm off work (I see above there's a known chafing issue). I've got 4 other bikes I could swap with if needed, so we'll cross that bridge when I get there.

    I'm adding to the list of issues I should be looking at (which I'm gathering from this thread).
    Last edited by motoguy; 05-25-2024 at 12:43 PM.

  2. #12
    Senior Member Barrett's Avatar
    Join Date
    Jun 2020
    Location
    AmishLand, PA
    Posts
    894
    MOTOGUY-----NO START

    Starter system receives its signal from the right side mounted starter switch which receives its power from the headlight circuit fuse and wiring. Start there.

  3. #13
    Senior Member
    Join Date
    Mar 2010
    Posts
    115
    Quote Originally Posted by Barrett View Post
    MOTOGUY-----NO START

    Starter system receives its signal from the right side mounted starter switch which receives its power from the headlight circuit fuse and wiring. Start there.
    Thank you! I'll check that wiring as well!

  4. #14
    Senior Member Barrett's Avatar
    Join Date
    Jun 2020
    Location
    AmishLand, PA
    Posts
    894
    Quote Originally Posted by ken woods View Post
    Sorry but me again , can someone tell me what resistance i could expect across my neutral switch when in neutral position and also is it possible to remove the IAC controller , plug it into the loom plug and run/ test it that way just to be sure

    As i am in australia , we do not cater for buell parts on every second corner , so before i go ordering parts overseas , i would like to make a better judgment . With the neutral switch unplugged at the moment , i have 110 ohms resistance across it with the bike in neutral and in gear ...... it goes open as would be expected

    thanks in advance , ken
    1-NO known test for IAC controller that is removed from the TB assembly.
    2-All HD XB--XL---XR neutral switches have ZERO ohms resistance as new.


    NEED TO CHECK:

    Both throttle cables routed properly and NOT hanging up causing erratic idle

    Emissions vacuum port plug has not fallen off vacuum canister plug on LEFT SIDE of throttle body

    Throttle body intake assembly intake port seals are failing check for vacuum leak front and rear with engine running



Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •